aboutsummaryrefslogtreecommitdiff
path: root/security/ocaml-cryptgps
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-03-26 22:36:46 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-03-26 22:36:46 +0000
commit0c186dcad598774b9f1eda444fd532fba12e80a7 (patch)
tree3cd974bf825389ae8ea942d466373c852a29b36d /security/ocaml-cryptgps
parent8fe3d0df7b78fdd6ced515ec2af01abe5853f7ff (diff)
downloadports-0c186dcad598774b9f1eda444fd532fba12e80a7.tar.gz
ports-0c186dcad598774b9f1eda444fd532fba12e80a7.zip
- Stage support
- Use USE_OCAMLFIND_PLIST instead of doing it manually
Notes
Notes: svn path=/head/; revision=349302
Diffstat (limited to 'security/ocaml-cryptgps')
-rw-r--r--security/ocaml-cryptgps/Makefile34
1 files changed, 9 insertions, 25 deletions
diff --git a/security/ocaml-cryptgps/Makefile b/security/ocaml-cryptgps/Makefile
index 65827ace1416..96f198a10f3c 100644
--- a/security/ocaml-cryptgps/Makefile
+++ b/security/ocaml-cryptgps/Makefile
@@ -14,36 +14,20 @@ COMMENT= Symmetric cryptographic algorithms package for OCaml
LICENSE= MIT
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
+USES= gmake
USE_OCAML= yes
-USE_OCAML_FINDLIB=yes
+USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
ALL_TARGET= all opt
-MASTERPORT= ${PORTSDIR}/devel/ocaml-camlidl
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-.endif
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-post-extract:
-# For nonstandard prefixes
-.if !exists(${OCAMLFIND_DESTDIR})
- ${MKDIR} ${OCAMLFIND_DESTDIR}
-.endif
-.if !exists(${OCAMLFIND_LDCONF})
- ${TOUCH} ${OCAMLFIND_LDCONF}
-.endif
+OPTIONS_DEFINE= DOCS
post-install:
- @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>