aboutsummaryrefslogtreecommitdiff
path: root/security/ocaml-cryptgps
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-04 16:25:22 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-04 16:25:22 +0000
commit5a283890144926f1087faf344f397740fc970ed4 (patch)
tree25d358287801dd0981893fd83b6606939e3ccbd3 /security/ocaml-cryptgps
parent11b25a256269ecb36f3b14315d51155073acfaac (diff)
downloadports-5a283890144926f1087faf344f397740fc970ed4.tar.gz
ports-5a283890144926f1087faf344f397740fc970ed4.zip
This library implements Blowfish, DES, and Triple-DES.
Author: Gerd Stolpmann WWW: http://www.ocaml-programming.de/packages/ PR: ports/101213 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Notes
Notes: svn path=/head/; revision=169685
Diffstat (limited to 'security/ocaml-cryptgps')
-rw-r--r--security/ocaml-cryptgps/Makefile51
-rw-r--r--security/ocaml-cryptgps/distinfo3
-rw-r--r--security/ocaml-cryptgps/pkg-descr4
3 files changed, 58 insertions, 0 deletions
diff --git a/security/ocaml-cryptgps/Makefile b/security/ocaml-cryptgps/Makefile
new file mode 100644
index 000000000000..229b4dd2180a
--- /dev/null
+++ b/security/ocaml-cryptgps/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: ocaml-cryptgps
+# Date created: 2006-08-01
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= cryptgps
+PORTVERSION= 0.2.1
+CATEGORIES= security
+MASTER_SITES= http://www.ocaml-programming.de/packages/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Symmetric cryptographic algorithms package for OCaml
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+ALL_TARGET= all opt
+MASTERPORT= ${PORTSDIR}/devel/ocaml-camlidl
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+.endif
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/ocaml-cryptgps/distinfo b/security/ocaml-cryptgps/distinfo
new file mode 100644
index 000000000000..079c909c09f8
--- /dev/null
+++ b/security/ocaml-cryptgps/distinfo
@@ -0,0 +1,3 @@
+MD5 (cryptgps-0.2.1.tar.gz) = 656afb40fa681079296551b546cb02df
+SHA256 (cryptgps-0.2.1.tar.gz) = 7a6c65531781e98c64277e908b8832f6321fe0a8c928cd6a7e89a7ca0489e7d6
+SIZE (cryptgps-0.2.1.tar.gz) = 37532
diff --git a/security/ocaml-cryptgps/pkg-descr b/security/ocaml-cryptgps/pkg-descr
new file mode 100644
index 000000000000..da49e1fa998d
--- /dev/null
+++ b/security/ocaml-cryptgps/pkg-descr
@@ -0,0 +1,4 @@
+This library implements Blowfish, DES, and Triple-DES.
+
+Author: Gerd Stolpmann
+WWW: http://www.ocaml-programming.de/packages/