aboutsummaryrefslogtreecommitdiff
path: root/security/ocaml-cryptokit
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-02-01 20:06:30 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-02-01 20:06:30 +0000
commit176d256471ad2b42a5643ff7960584cd90ad5481 (patch)
tree90c5a5d1fdc2120df9ec2dbedd6a63d97a45e716 /security/ocaml-cryptokit
parent8024910f7ac381e80fc4a99afc0f8d39c9067077 (diff)
downloadports-176d256471ad2b42a5643ff7960584cd90ad5481.tar.gz
ports-176d256471ad2b42a5643ff7960584cd90ad5481.zip
- Update to 1.5
- support for oasis and findlib - added blowfish and MAC support along with bugfixes - plist is removed in favor of generation via findlib - remove META from FILESDIR, as it is now distributed - maintainer address update PR: ports/164661 Submitted by: maintainer, Jaap.Boender at pps.jussieu.fr Approved by: crees (mentor)
Notes
Notes: svn path=/head/; revision=290254
Diffstat (limited to 'security/ocaml-cryptokit')
-rw-r--r--security/ocaml-cryptokit/Makefile46
-rw-r--r--security/ocaml-cryptokit/distinfo4
-rw-r--r--security/ocaml-cryptokit/files/META6
-rw-r--r--security/ocaml-cryptokit/files/patch-Makefile14
-rw-r--r--security/ocaml-cryptokit/pkg-plist11
5 files changed, 12 insertions, 69 deletions
diff --git a/security/ocaml-cryptokit/Makefile b/security/ocaml-cryptokit/Makefile
index 36904960a196..aaf4433bcf80 100644
--- a/security/ocaml-cryptokit/Makefile
+++ b/security/ocaml-cryptokit/Makefile
@@ -6,56 +6,30 @@
#
PORTNAME= cryptokit
-PORTVERSION= 1.3
-PORTREVISION= 4
+PORTVERSION= 1.5
CATEGORIES= security
-MASTER_SITES= http://caml.inria.fr/distrib/bazar-ocaml/
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/639/
PKGNAMEPREFIX= ocaml-
-MAINTAINER= Jaap.Boender@pps.jussieu.fr
+MAINTAINER= jaapb@kerguelen.org
COMMENT= A variety of cryptographic primitives for Objective Caml
+HAS_CONFIGURE= yes
+
USE_OCAML= yes
USE_OCAML_LDCONFIG= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
MAKE_JOBS_SAFE= yes
-ALL_TARGET= all allopt
-
.ifndef(NOPORTDOCS)
ALL_TARGET+= doc
+CONFIGURE_ARGS+= --docdir ${PREFIX}/share/doc/ocaml
PORTDOCS= *
.endif
DOC_FILES= Changes LICENSE README
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-post-configure:
-# CFLAGS,PREFIX safeness
- @${REINPLACE_CMD} -E -e \
- 's|^(INSTALLDIR).*$$|\1=${PREFIX}/${OCAML_SITELIBDIR}/${PORTNAME}|; \
- s|^CFLAGS=|CFLAGS\+=|; \
- s|(^CFLAGS.*)-O|\1|' \
- ${WRKSRC}/Makefile
-
-pre-install:
-# in pre-install to make sure we're using the correct user:group
-# combo
- @${REINPLACE_CMD} -E -e \
- 's|cp |${INSTALL_DATA} |' \
- ${WRKSRC}/Makefile
-
-post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/doc
- @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/doc
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
- @${INSTALL_DATA} ${FILESDIR}/META ${PREFIX}/${OCAML_SITELIBDIR}/${PORTNAME}
-
-.include <bsd.port.pre.mk>
-
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/ocaml-cryptokit/distinfo b/security/ocaml-cryptokit/distinfo
index 25ff3d6da79b..f0c8f756478f 100644
--- a/security/ocaml-cryptokit/distinfo
+++ b/security/ocaml-cryptokit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cryptokit-1.3.tar.gz) = 9ef339ed4cb15f0c458d0093b90dd249d8d1dfb1b01a1fedc542e67f67a7194f
-SIZE (cryptokit-1.3.tar.gz) = 112689
+SHA256 (cryptokit-1.5.tar.gz) = e2483a463ea57eee99c1e9c5aed1c34885255e47f0d4d872bb2bb3a8975eb3e4
+SIZE (cryptokit-1.5.tar.gz) = 128907
diff --git a/security/ocaml-cryptokit/files/META b/security/ocaml-cryptokit/files/META
deleted file mode 100644
index 4fed14e3aaae..000000000000
--- a/security/ocaml-cryptokit/files/META
+++ /dev/null
@@ -1,6 +0,0 @@
-name="cryptokit"
-version="1.3"
-description="A variety of cryptographic primitives for Objective Caml"
-requires="unix,num"
-archive(byte)="cryptokit.cma"
-archive(native)="cryptokit.cmxa"
diff --git a/security/ocaml-cryptokit/files/patch-Makefile b/security/ocaml-cryptokit/files/patch-Makefile
deleted file mode 100644
index b2c8a0d7d790..000000000000
--- a/security/ocaml-cryptokit/files/patch-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.orig 2011-03-02 06:09:16.000000000 +0000
-+++ Makefile 2011-03-02 06:10:20.000000000 +0000
-@@ -74,9 +74,10 @@
- rm -f speedtest
-
- install:
-+ install -d $(INSTALLDIR)
- cp cryptokit.cmi cryptokit.cma cryptokit.mli $(INSTALLDIR)
- cp libcryptokit.a $(INSTALLDIR)
-- if test -f dllcryptokit.so; then cp dllcryptokit.so $(INSTALLDIR)/stublibs; fi
-+ if test -f dllcryptokit.so; then cp dllcryptokit.so $(INSTALLDIR); fi
- if test -f cryptokit.cmxa; then cp cryptokit.cmxa cryptokit.cmx cryptokit.a $(INSTALLDIR); fi
-
- doc: FORCE
diff --git a/security/ocaml-cryptokit/pkg-plist b/security/ocaml-cryptokit/pkg-plist
deleted file mode 100644
index 3ed9b016c160..000000000000
--- a/security/ocaml-cryptokit/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-%%OCAML_SITELIBDIR%%/cryptokit/META
-%%OCAML_SITELIBDIR%%/cryptokit/cryptokit.a
-%%OCAML_SITELIBDIR%%/cryptokit/cryptokit.cma
-%%OCAML_SITELIBDIR%%/cryptokit/cryptokit.cmi
-%%OCAML_SITELIBDIR%%/cryptokit/cryptokit.cmx
-%%OCAML_SITELIBDIR%%/cryptokit/cryptokit.cmxa
-%%OCAML_SITELIBDIR%%/cryptokit/cryptokit.mli
-%%OCAML_SITELIBDIR%%/cryptokit/libcryptokit.a
-%%OCAML_SITELIBDIR%%/cryptokit/dllcryptokit.so
-@dirrmtry %%OCAML_SITELIBDIR%%/cryptokit
-@dirrmtry %%OCAML_SITELIBDIR%%