aboutsummaryrefslogtreecommitdiff
path: root/security/op
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-05-17 22:22:53 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-05-17 22:22:53 +0000
commit9dbe1ad3ebf885b0cf7179ba3f7312f93047dab3 (patch)
treeac720222dd3d8f585e08609f7e0b6039235bfc8f /security/op
parent215dbbe3c871a1f89ff45c6ece3d3a9f59d9a600 (diff)
downloadports-9dbe1ad3ebf885b0cf7179ba3f7312f93047dab3.tar.gz
ports-9dbe1ad3ebf885b0cf7179ba3f7312f93047dab3.zip
honor CFLAGS.
PR: ports/37112 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59354
Diffstat (limited to 'security/op')
-rw-r--r--security/op/Makefile6
-rw-r--r--security/op/files/patch-lex.l10
2 files changed, 14 insertions, 2 deletions
diff --git a/security/op/Makefile b/security/op/Makefile
index 96cc3cec217f..388644a94c21 100644
--- a/security/op/Makefile
+++ b/security/op/Makefile
@@ -57,11 +57,13 @@ checkout-files:
post-patch: patch-makefile patch-conf-file
patch-makefile:
- @${PERL} -pi.fbsd -e 's|(install)|$$1 -c| if (!/:/);' \
+ @${PERL} -pi.fbsd \
+ -e 's|(install)|$$1 -c| if (!/:/);s|CFLAGS=|CFLAGS+=|' \
${WRKSRC}/Makefile
patch-conf-file:
- @${PERL} -pi.fbsd -e 's|^|#| if (!/^#|DEFAULT|MAGIC/);s|/usr/ucb:||;' \
+ @${PERL} -pi.fbsd \
+ -e 's|^|#| if (!/^#|DEFAULT|MAGIC/);s|/usr/ucb:||' \
${WRKSRC}/${CONF_FILE}
# Post-install
diff --git a/security/op/files/patch-lex.l b/security/op/files/patch-lex.l
new file mode 100644
index 000000000000..a19bdc55ada7
--- /dev/null
+++ b/security/op/files/patch-lex.l
@@ -0,0 +1,10 @@
+--- lex.l.orig Mon Apr 15 23:30:47 2002
++++ lex.l Mon Apr 15 23:30:18 2002
+@@ -14,6 +14,7 @@
+ #include <ctype.h>
+ #include "defs.h"
+
++static int addarg();
+ static cmd_t *newcmd();
+ char *savestr();
+