aboutsummaryrefslogtreecommitdiff
path: root/security/openconnect-gui
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-12 04:30:49 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-12 04:30:49 +0000
commit05309a97a64d3ecb8931d5eca641e627c624b813 (patch)
tree64df6cf81a46018839291f39e0aeb1cd808568a0 /security/openconnect-gui
parent1ff839cfd6056897f465c41ca884914f139f28df (diff)
downloadports-05309a97a64d3ecb8931d5eca641e627c624b813.tar.gz
ports-05309a97a64d3ecb8931d5eca641e627c624b813.zip
Fix build on gcc-based architectures:
The compiler feature "cxx_decltype" is not known to CXX compiler While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=495426
Diffstat (limited to 'security/openconnect-gui')
-rw-r--r--security/openconnect-gui/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/openconnect-gui/Makefile b/security/openconnect-gui/Makefile
index 1d375441203c..2c78bb0c23ae 100644
--- a/security/openconnect-gui/Makefile
+++ b/security/openconnect-gui/Makefile
@@ -3,8 +3,8 @@
PORTNAME= openconnect-gui
PORTVERSION= 1.4.1
-PORTREVISION= 2
DISTVERSIONPREFIX=v
+PORTREVISION= 2
CATEGORIES= security
MAINTAINER= pkubaj@anongoth.pl
@@ -18,10 +18,10 @@ LIB_DEPENDS= libgnutls.so:security/gnutls
RUN_DEPENDS= openconnect:security/openconnect \
vpnc-scripts>=0:sysutils/vpnc-scripts
+USES= cmake:insource compiler:c++11-lang pkgconfig qt:5
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME:C/-gui//}
-USES= cmake:insource pkgconfig qt:5
USE_QT= buildtools_build concurrent core gui network qmake_build widgets
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=Release
PLIST_FILES= bin/openconnect-gui