aboutsummaryrefslogtreecommitdiff
path: root/security/openconnect-gui
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-26 01:10:29 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-26 01:10:29 +0000
commite505dec962d2cd6d022c6dcae948e1060268f3cd (patch)
tree4240a4e075b0fde335a1087005ce10e2cd2d6ce0 /security/openconnect-gui
parenta5f8391dda80d358250e39d0ab666ea94530448f (diff)
downloadports-e505dec962d2cd6d022c6dcae948e1060268f3cd.tar.gz
ports-e505dec962d2cd6d022c6dcae948e1060268f3cd.zip
security/openconnect-gui: update to 1.5.3
PR: 253609 Submitted by: swills
Notes
Notes: svn path=/head/; revision=566575
Diffstat (limited to 'security/openconnect-gui')
-rw-r--r--security/openconnect-gui/Makefile14
-rw-r--r--security/openconnect-gui/distinfo8
-rw-r--r--security/openconnect-gui/files/patch-CMakeLists.txt12
-rw-r--r--security/openconnect-gui/files/patch-CMake_Includes_ProjectDependencies.cmake11
-rw-r--r--security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals.cmake10
-rw-r--r--security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake33
-rw-r--r--security/openconnect-gui/files/patch-CMake_Includes_git__revision__main.cmake21
-rw-r--r--security/openconnect-gui/files/patch-src_FileLogger.h10
-rw-r--r--security/openconnect-gui/files/patch-src_dialog_mainwindow.cpp11
-rw-r--r--security/openconnect-gui/files/patch-src_vpninfo.cpp11
-rw-r--r--security/openconnect-gui/files/patch-src_vpninfo.h11
11 files changed, 102 insertions, 50 deletions
diff --git a/security/openconnect-gui/Makefile b/security/openconnect-gui/Makefile
index 7f8767736b40..fff1b89055b2 100644
--- a/security/openconnect-gui/Makefile
+++ b/security/openconnect-gui/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= openconnect-gui
-PORTVERSION= 1.4.1
+PORTVERSION= 1.5.3
DISTVERSIONPREFIX=v
-PORTREVISION= 4
+MASTER_SITES= https://gitlab.com/openconnect/openconnect-gui/-/archive/v${PORTVERSION}/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
CATEGORIES= security net-vpn
MAINTAINER= pkubaj@FreeBSD.org
@@ -14,14 +15,15 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= openconnect:security/openconnect
-LIB_DEPENDS= libgnutls.so:security/gnutls
+LIB_DEPENDS= libgnutls.so:security/gnutls \
+ libspdlog.so:devel/spdlog \
+ libfmt.so:devel/libfmt
RUN_DEPENDS= openconnect:security/openconnect \
vpnc-scripts>=0:sysutils/vpnc-scripts
USES= cmake:insource compiler:c++11-lang pkgconfig qt:5
-USE_GITHUB= yes
-GH_ACCOUNT= ${PORTNAME:C/-gui//}
-
+USE_GITHUB= nodefault
+GH_TUPLE= qtproject:qt-solutions:a8dda66d:qtsolutions/external/src/qt-solutions-master
USE_QT= buildtools_build concurrent core gui network qmake_build widgets
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=Release
PLIST_FILES= bin/openconnect-gui
diff --git a/security/openconnect-gui/distinfo b/security/openconnect-gui/distinfo
index 1e38ca03a4e9..ad5d52fe9440 100644
--- a/security/openconnect-gui/distinfo
+++ b/security/openconnect-gui/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1611572481
-SHA256 (openconnect-openconnect-gui-v1.4.1_GH0.tar.gz) = 5f609e10eafc8885699e503c1dca9d9154d18741cfd09c1222d05b8af448c1d1
-SIZE (openconnect-openconnect-gui-v1.4.1_GH0.tar.gz) = 10026785
+TIMESTAMP = 1613608872
+SHA256 (openconnect-gui-v1.5.3.tar.gz) = 339858502dfa808155c854b47da32a6c0e9ea315d028d2cadd9dcf84a952ae42
+SIZE (openconnect-gui-v1.5.3.tar.gz) = 14672366
+SHA256 (qtproject-qt-solutions-a8dda66d_GH0.tar.gz) = 24d1a47ed0d2cc1f3a858c40c57482080cdbf88441386cfb0628b7e81de69800
+SIZE (qtproject-qt-solutions-a8dda66d_GH0.tar.gz) = 1410481
diff --git a/security/openconnect-gui/files/patch-CMakeLists.txt b/security/openconnect-gui/files/patch-CMakeLists.txt
index f5057cc41f4c..684409b827d2 100644
--- a/security/openconnect-gui/files/patch-CMakeLists.txt
+++ b/security/openconnect-gui/files/patch-CMakeLists.txt
@@ -1,14 +1,12 @@
---- CMakeLists.txt.orig 2017-07-18 18:47:18.951816000 +0000
-+++ CMakeLists.txt 2017-07-18 18:49:23.953701000 +0000
-@@ -13,15 +13,7 @@ set(PRODUCT_NAME_COMPANY_DOMAIN "redhat.com")
- set(PRODUCT_NAME_COPYRIGHT "Copyright (C) 2015-2016 Red Hat Inc.")
-
+--- CMake/Includes/ProjectSettings.cmake.orig 2021-02-18 00:06:43 UTC
++++ CMake/Includes/ProjectSettings.cmake
+@@ -1,13 +1,5 @@
option(PROJ_GNUTLS_DEBUG "Enable GnuTLS debug mode" OFF)
--if(WIN32 AND MINGW)
+-if(MINGW)
- option(PROJ_UAC_ON "Enable UAC (don't turn it off in production)" ON)
-
- set(DEFAULT_VPNC_SCRIPT "vpnc-script.js")
--else(APPLE)
+-elseif(APPLE)
- set(DEFAULT_VPNC_SCRIPT "../Resources/vpnc-script")
-else()
- set(DEFAULT_VPNC_SCRIPT "/etc/vpnc/vpnc-script")
diff --git a/security/openconnect-gui/files/patch-CMake_Includes_ProjectDependencies.cmake b/security/openconnect-gui/files/patch-CMake_Includes_ProjectDependencies.cmake
new file mode 100644
index 000000000000..9f3dd5c09e4d
--- /dev/null
+++ b/security/openconnect-gui/files/patch-CMake_Includes_ProjectDependencies.cmake
@@ -0,0 +1,11 @@
+--- CMake/Includes/ProjectDependencies.cmake.orig 2021-02-18 00:27:05 UTC
++++ CMake/Includes/ProjectDependencies.cmake
+@@ -36,7 +36,7 @@ if(UNIX)
+ message(FATAL_ERROR "Libraru 'OpenConnect' not found! Install it vie e.g. 'brew install openconnect or 'dnf install openconnect'")
+ endif()
+
+- #find_package(spdlog CONFIG REQUIRED)
++ find_package(spdlog CONFIG REQUIRED)
+
+ set(CMAKE_THREAD_PREFER_PTHREAD ON)
+ find_package(Threads REQUIRED)
diff --git a/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals.cmake b/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals.cmake
new file mode 100644
index 000000000000..aa7066bd3835
--- /dev/null
+++ b/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals.cmake
@@ -0,0 +1,10 @@
+--- CMake/Includes/ProjectExternals.cmake.orig 2018-03-25 21:49:15 UTC
++++ CMake/Includes/ProjectExternals.cmake
+@@ -22,7 +22,6 @@ include(ExternalProject)
+
+ file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/external/include)
+
+-include(ProjectExternals_spdlog)
+ include(ProjectExternals_qt-solutions)
+ if(MINGW)
+ include(ProjectExternals_openconnect)
diff --git a/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake b/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake
new file mode 100644
index 000000000000..3604ecf590cc
--- /dev/null
+++ b/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake
@@ -0,0 +1,33 @@
+--- CMake/Includes/ProjectExternals_qt-solutions.cmake.orig 2018-03-25 21:49:15 UTC
++++ CMake/Includes/ProjectExternals_qt-solutions.cmake
+@@ -9,10 +9,7 @@ ExternalProject_Add(qt-solutions-${qt-solutions-TAG}
+ UPDATE_DISCONNECTED 0
+ UPDATE_COMMAND ""
+
+- GIT_REPOSITORY https://code.qt.io/qt-solutions/qt-solutions.git
+- GIT_TAG ${qt-solutions-TAG}
+- GIT_SHALLOW 1
+-
++ SOURCE_DIR ${CMAKE_BINARY_DIR}/external/src/qt-solutions-master
+ BUILD_IN_SOURCE 1
+
+ PATCH_COMMAND ${CMAKE_COMMAND} -E copy_if_different
+@@ -21,14 +18,14 @@ ExternalProject_Add(qt-solutions-${qt-solutions-TAG}
+ CMAKE_COMMAND ${CMAKE_CROSS_COMMAND} -DCMAKE_OSX_DEPLOYMENT_TARGET=${CMAKE_OSX_DEPLOYMENT_TARGET}
+
+ # Note: ninja-1.8.2 & cmake-3.10.2 failed in find/install this dependency wo next 2 lines :(
+- BUILD_BYPRODUCTS ${CMAKE_BINARY_DIR}/external/lib/libqtsingleapplication.a
+- INSTALL_COMMAND ${CMAKE_COMMAND} --build . --target install
++ BUILD_BYPRODUCTS ${CMAKE_BINARY_DIR}/external/src/qt-solutions-master/libqtsingleapplication.a
++ INSTALL_COMMAND ${CMAKE_COMMAND} --build .
+ )
+
+ add_library(qt-solutions::qtsingleapplication STATIC IMPORTED)
+ set_target_properties(qt-solutions::qtsingleapplication PROPERTIES
+- INTERFACE_INCLUDE_DIRECTORIES "${CMAKE_BINARY_DIR}/external/include"
+- IMPORTED_LOCATION ${CMAKE_BINARY_DIR}/external/lib/libqtsingleapplication.a
++ INTERFACE_INCLUDE_DIRECTORIES "${CMAKE_BINARY_DIR}/external/src/qt-solutions-master/qtsingleapplication/src"
++ IMPORTED_LOCATION ${CMAKE_BINARY_DIR}/external/src/qt-solutions-master/libqtsingleapplication.a
+ )
+ set_property(TARGET qt-solutions::qtsingleapplication PROPERTY
+ DEPENDS qt-solutions-${qt-solutions-TAG}
diff --git a/security/openconnect-gui/files/patch-CMake_Includes_git__revision__main.cmake b/security/openconnect-gui/files/patch-CMake_Includes_git__revision__main.cmake
index 15ea1966dda1..5cf147facbcc 100644
--- a/security/openconnect-gui/files/patch-CMake_Includes_git__revision__main.cmake
+++ b/security/openconnect-gui/files/patch-CMake_Includes_git__revision__main.cmake
@@ -1,28 +1,25 @@
-Has been submitted upstream. With ninja, the generated file
-is not recognized as a dependency and not generated before it is
-#included from other code.
-
---- CMake/Includes/git_revision_main.cmake.orig 2016-08-28 20:11:26 UTC
+--- CMake/Includes/git_revision_main.cmake.orig 2021-02-18 00:09:34 UTC
+++ CMake/Includes/git_revision_main.cmake
-@@ -4,9 +4,9 @@ if(IS_DIRECTORY ${PROJECT_SOURCE_DIR}/.git)
+@@ -4,9 +4,8 @@ if(IS_DIRECTORY ${PROJECT_SOURCE_DIR}/.git)
find_package(Git 2.7 REQUIRED)
endif()
-add_custom_target(git_revision ALL)
add_custom_command(
- TARGET git_revision
-+# TARGET git_revision
+ OUTPUT ${CMAKE_SOURCE_DIR}/src/${PROJECT_NAME}.cpp
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src
COMMAND ${CMAKE_COMMAND}
-@@ -35,5 +35,8 @@ add_custom_command(
+@@ -35,6 +34,11 @@ add_custom_command(
+ -DAPPLE=${APPLE}
-P ${CMAKE_SOURCE_DIR}/CMake/Includes/git_revision_generate.cmake
COMMENT "Analyzing Git revision/tag changes..." VERBATIM
- )
--
++)
++
+add_custom_target(
+ git_revision
+ DEPENDS ${CMAKE_SOURCE_DIR}/src/${PROJECT_NAME}.cpp
-+)
- add_dependencies(${PROJECT_NAME} git_revision)
+ )
+
+ # explicitly say that the executable depends on the git_revision
diff --git a/security/openconnect-gui/files/patch-src_FileLogger.h b/security/openconnect-gui/files/patch-src_FileLogger.h
new file mode 100644
index 000000000000..d45920407d2d
--- /dev/null
+++ b/security/openconnect-gui/files/patch-src_FileLogger.h
@@ -0,0 +1,10 @@
+--- src/FileLogger.h.orig 2021-02-18 01:03:58 UTC
++++ src/FileLogger.h
+@@ -1,6 +1,7 @@
+ #pragma once
+
+ #include "spdlog/spdlog.h"
++#include "spdlog/sinks/rotating_file_sink.h"
+
+ #include <QObject>
+ #include <QStandardPaths>
diff --git a/security/openconnect-gui/files/patch-src_dialog_mainwindow.cpp b/security/openconnect-gui/files/patch-src_dialog_mainwindow.cpp
new file mode 100644
index 000000000000..7741060b8008
--- /dev/null
+++ b/security/openconnect-gui/files/patch-src_dialog_mainwindow.cpp
@@ -0,0 +1,11 @@
+--- src/dialog/mainwindow.cpp.orig 2021-02-18 01:06:48 UTC
++++ src/dialog/mainwindow.cpp
+@@ -934,7 +934,7 @@ void MainWindow::on_actionAbout_triggered()
+ txt += tr("<br>Based on");
+ txt += tr("<br>- <a href=\"https://www.infradead.org/openconnect\">OpenConnect</a> ") + QLatin1String(openconnect_get_version());
+ txt += tr("<br>- <a href=\"https://www.gnutls.org\">GnuTLS</a> v") + QLatin1String(gnutls_check_version(nullptr));
+- txt += tr("<br>- <a href=\"https://github.com/gabime/spdlog\">spdlog</a> v") + QLatin1String(SPDLOG_VERSION);
++ txt += tr("<br>- <a href=\"https://github.com/gabime/spdlog\">spdlog</a>");
+ txt += tr("<br>- <a href=\"https://www.qt.io\">Qt</a> v%1").arg(QT_VERSION_STR);
+ txt += tr("<br><br>%1<br>").arg(appCopyright);
+ txt += tr("<br><i>%1</i> comes with ABSOLUTELY NO WARRANTY. This is free software, "
diff --git a/security/openconnect-gui/files/patch-src_vpninfo.cpp b/security/openconnect-gui/files/patch-src_vpninfo.cpp
deleted file mode 100644
index 90d3897d1374..000000000000
--- a/security/openconnect-gui/files/patch-src_vpninfo.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/vpninfo.cpp.orig 2016-09-21 11:15:03 UTC
-+++ src/vpninfo.cpp
-@@ -427,6 +427,8 @@ int VpnInfo::connect()
- const QString osName{"mac-intel"};
- #elif defined Q_OS_LINUX
- const QString osName = QString("linux%1").arg(QSysInfo::buildCpuArchitecture() == "i386" ? "" : "-64").toStdString().c_str();
-+#elif defined Q_OS_FREEBSD
-+ const QString osName = QString("freebsd%1").arg(QSysInfo::buildCpuArchitecture() == "i386" ? "" : "-64").toStdString().c_str();
- #else
- #error Define OS string of other platforms...
- #endif
diff --git a/security/openconnect-gui/files/patch-src_vpninfo.h b/security/openconnect-gui/files/patch-src_vpninfo.h
deleted file mode 100644
index 707f4ba83c22..000000000000
--- a/security/openconnect-gui/files/patch-src_vpninfo.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/vpninfo.h.orig 2016-08-28 20:11:26 UTC
-+++ src/vpninfo.h
-@@ -23,7 +23,7 @@
- #ifdef _WIN32
- #include <winsock2.h>
- #endif
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- #define SOCKET int
- #endif
-