aboutsummaryrefslogtreecommitdiff
path: root/security/openconnect
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-24 11:34:51 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-24 11:34:51 +0000
commitc3e6deebb6ac7a4110bc993664efac7e14b4e99e (patch)
tree501e11dbe2d8b7fd62561a9fdc97f62bb4a0e874 /security/openconnect
parent0965c62ee4caf4a1fd6a5187409105a8d00131d5 (diff)
downloadports-c3e6deebb6ac7a4110bc993664efac7e14b4e99e.tar.gz
ports-c3e6deebb6ac7a4110bc993664efac7e14b4e99e.zip
- Unbreak GnuTLS support for 7.x and 8.x
Notes
Notes: svn path=/head/; revision=299869
Diffstat (limited to 'security/openconnect')
-rw-r--r--security/openconnect/Makefile3
-rw-r--r--security/openconnect/files/patch-gnutls.c11
2 files changed, 11 insertions, 3 deletions
diff --git a/security/openconnect/Makefile b/security/openconnect/Makefile
index 341c32f5f231..d8079fae38e3 100644
--- a/security/openconnect/Makefile
+++ b/security/openconnect/Makefile
@@ -42,9 +42,6 @@ GNUTLS_DESC= Use GnuTLS instead of OpenSSL(EXPERIMENTAL)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUTLS}
-.if ${OSVERSION} < 900007
-BROKEN= GnuTLS support currently requires FreeBSD 9.x or above
-.endif
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--with-gnutls
.endif
diff --git a/security/openconnect/files/patch-gnutls.c b/security/openconnect/files/patch-gnutls.c
new file mode 100644
index 000000000000..72e6df0130ac
--- /dev/null
+++ b/security/openconnect/files/patch-gnutls.c
@@ -0,0 +1,11 @@
+--- ./gnutls.c.orig 2012-06-24 07:29:27.000000000 -0400
++++ ./gnutls.c 2012-06-24 07:29:43.000000000 -0400
+@@ -239,7 +239,7 @@
+ /* For systems that don't support O_CLOEXEC, just don't bother.
+ It's not open for long anyway. */
+ #ifndef O_CLOEXEC
+-#define O_CLOEXEC
++#define O_CLOEXEC 0
+ #endif
+
+ static int load_datum(struct openconnect_info *vpninfo,