aboutsummaryrefslogtreecommitdiff
path: root/security/opensc
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-05-13 12:33:16 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-05-13 12:33:16 +0000
commit6d5419e9309f2e60369d407a24dc1b86339ba3b7 (patch)
tree9f41969a82dd48ed060266bfdd5ed3c2ba34128b /security/opensc
parentcd4f9df7528b5afb9e24dc57337e6e7010e83395 (diff)
downloadports-6d5419e9309f2e60369d407a24dc1b86339ba3b7.tar.gz
ports-6d5419e9309f2e60369d407a24dc1b86339ba3b7.zip
Modernize.
Notes
Notes: svn path=/head/; revision=353944
Diffstat (limited to 'security/opensc')
-rw-r--r--security/opensc/Makefile15
-rw-r--r--security/opensc/pkg-descr2
-rw-r--r--security/opensc/pkg-plist2
3 files changed, 6 insertions, 13 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index db086e347aa2..8e935825b506 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -24,7 +24,7 @@ OPENCT_DESC= Use OpenCT backend
CTAPI_DESC= Use CT-API backend
SM_DESC= Enable secure messaging support
-USES= pkgconfig gmake
+USES= libtool:keepla pkgconfig gmake
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -41,12 +41,12 @@ PORTDOCS= *
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENCT}
-LIB_DEPENDS+= openct:${PORTSDIR}/security/openct
+LIB_DEPENDS+= libopenct.so:${PORTSDIR}/security/openct
CONFIGURE_ARGS+=--enable-openct
.endif
.if ${PORT_OPTIONS:MPCSC}
-LIB_DEPENDS+= pcsclite:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS+= libpcsclite.so:${PORTSDIR}/devel/pcsc-lite
.else
CONFIGURE_ARGS+=--disable-pcsc
.endif
@@ -69,14 +69,5 @@ CONFIGURE_ARGS+=--enable-doc
post-patch:
@${REINPLACE_CMD} 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/configure
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} 's|install-data-am: install-dist_docDATA|install-data-am:|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} 's|install-data-am: install-htmlDATA install-man|install-data-am: install-man|' \
- ${WRKSRC}/doc/Makefile.in ${WRKSRC}/doc/tools/Makefile.in
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/security/opensc/pkg-descr b/security/opensc/pkg-descr
index 2e4a15364f67..1d2e83a7e77a 100644
--- a/security/opensc/pkg-descr
+++ b/security/opensc/pkg-descr
@@ -11,4 +11,4 @@ Thunderbird can use it.
OpenSC implements the PKCS#15 standard and aims to be
compatible with every software that does so, too.
-WWW: http://www.opensc-project.org/opensc/
+WWW: https://github.com/OpenSC/OpenSC/wiki
diff --git a/security/opensc/pkg-plist b/security/opensc/pkg-plist
index b4b6c63ac51b..6fde7d65b286 100644
--- a/security/opensc/pkg-plist
+++ b/security/opensc/pkg-plist
@@ -18,10 +18,12 @@ lib/libopensc.a
lib/libopensc.la
lib/libopensc.so
lib/libopensc.so.3
+lib/libopensc.so.3.0.0
%%SM%%lib/libsmm-local.a
%%SM%%lib/libsmm-local.la
%%SM%%lib/libsmm-local.so
%%SM%%lib/libsmm-local.so.3
+%%SM%%lib/libsmm-local.so.3.0.0
lib/opensc-pkcs11.la
lib/opensc-pkcs11.so
lib/pkcs11-spy.la