aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-askpass
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-05-06 06:18:19 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-05-06 06:18:19 +0000
commit41ecefa5dd94c9563d10b8db3cb5bdb45ede9b83 (patch)
treeae42f18f0d3bf5552ee8abe2bb3cb3154c1a1144 /security/openssh-askpass
parent697f1c2aa446d7ef05ffc9f795185dab1833b03d (diff)
downloadports-41ecefa5dd94c9563d10b8db3cb5bdb45ede9b83.tar.gz
ports-41ecefa5dd94c9563d10b8db3cb5bdb45ede9b83.zip
- Fix dependency.
- Remove USE_IMAKE and USE_GCC=any.
Notes
Notes: svn path=/head/; revision=317465
Diffstat (limited to 'security/openssh-askpass')
-rw-r--r--security/openssh-askpass/Makefile10
-rw-r--r--security/openssh-askpass/files/Makefile.in49
2 files changed, 53 insertions, 6 deletions
diff --git a/security/openssh-askpass/Makefile b/security/openssh-askpass/Makefile
index b5c38a216646..7fd58e3062f4 100644
--- a/security/openssh-askpass/Makefile
+++ b/security/openssh-askpass/Makefile
@@ -3,6 +3,7 @@
PORTNAME= OpenSSH-askpass
PORTVERSION= 1.2.4.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.jmknoble.net/software/x11-ssh-askpass/
DISTNAME= x11-ssh-askpass-${PORTVERSION}
@@ -10,10 +11,7 @@ DISTNAME= x11-ssh-askpass-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Graphical password applet for entering SSH passphrase
-USE_IMAKE= yes
-USE_GCC= any
-USE_XORG= x11 xt
-
+USE_XORG= x11 xt sm ice
DOCSDIR= ${PREFIX}/share/doc/ssh-askpass
PLIST_FILES= bin/x11-ssh-askpass \
bin/ssh-askpass \
@@ -27,8 +25,8 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-pre-configure:
- cd ${WRKSRC} && ./configure --libexecdir=${PREFIX}/bin
+post-extract:
+ ${INSTALL_DATA} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
.if ${PORT_OPTIONS:MDOCS}
post-install:
diff --git a/security/openssh-askpass/files/Makefile.in b/security/openssh-askpass/files/Makefile.in
new file mode 100644
index 000000000000..53cfa35066cb
--- /dev/null
+++ b/security/openssh-askpass/files/Makefile.in
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PREFIX?= /usr/local
+LOCALBASE?= /usr/local
+BINDIR?= ${PREFIX}/bin
+MANDIR?= ${PREFIX}/man/man
+NO_MANCOMPRESS=
+
+CLASS= SshAskpass
+FILES= ${CLASS}
+FILESDIR?= ${PREFIX}/lib/X11/app-defaults
+
+PROG= x11-ssh-askpass
+
+SRCS= drawing.c dynlist.c resources.c x11-ssh-askpass.c
+LDADD= -lXt -lX11 -lSM -lICE -L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib
+CFLAGS+=-I${LOCALBASE}/include -DCSRG_BASED -DFUNCPROTO=15 -DNARROWPROTO
+MAN= ${PROG}.1
+
+${PROG}.1: x11-ssh-askpass.man.in
+ sed -e 's|@NAME@|${PROG}|' \
+ -e 's|@DATE@|September 17, 2001|'\
+ -e 's|@VERSION@|1.2.4.1|'\
+ < $? > $@
+
+${CLASS}: ${CLASS}.ad
+ cp $? $@
+
+${CLASS}.ad: ${CLASS}-default.ad
+ cp $? $@
+
+${CLASS}_ad.h: ${CLASS}.ad
+ sed -n '/^[^!]/s/.*/"&",/p' < $? >$@.tmp
+ mv $@.tmp $@
+
+${PROG}: ${CLASS}_ad.h
+CLEANFILES+= ${CLASS}_ad.h
+
+ssh-askpass: ${PROG}
+ ln -s -f $? $@
+
+beforeinstall:
+ mkdir -p ${FILESDIR}
+
+afterinstall:
+ ln -s -f ${PROG} ${BINDIR}/ssh-askpass
+ ln -s -f ${PROG}.1 ${MANDIR}1/ssh-askpass.1
+
+.include <bsd.prog.mk>