aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-askpass
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-02-28 06:51:15 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-02-28 06:51:15 +0000
commitb62cf310968d12854c16608e9c7ce83e6e0face2 (patch)
tree6b48d0b751a10042d4a4f44cca4249bf2e8a9bf0 /security/openssh-askpass
parentb0c208617217898049f485c60f3e1e5a81d8593c (diff)
downloadports-b62cf310968d12854c16608e9c7ce83e6e0face2.tar.gz
ports-b62cf310968d12854c16608e9c7ce83e6e0face2.zip
ssh-askpass is a small X app which OpenSSH's ssh-add(1) will try and spawn
if called without a controlling terminal, e.g. if called during the X login process. It is somewhat configurable through app-defaults. Makefile shamelessly ripped from: green's OpenSSH port.
Notes
Notes: svn path=/head/; revision=26403
Diffstat (limited to 'security/openssh-askpass')
-rw-r--r--security/openssh-askpass/Makefile96
-rw-r--r--security/openssh-askpass/distinfo32
-rw-r--r--security/openssh-askpass/files/distfiles16
-rw-r--r--security/openssh-askpass/files/ignorefiles16
-rw-r--r--security/openssh-askpass/pkg-comment1
-rw-r--r--security/openssh-askpass/pkg-descr8
-rw-r--r--security/openssh-askpass/pkg-plist4
7 files changed, 173 insertions, 0 deletions
diff --git a/security/openssh-askpass/Makefile b/security/openssh-askpass/Makefile
new file mode 100644
index 000000000000..981f894b9809
--- /dev/null
+++ b/security/openssh-askpass/Makefile
@@ -0,0 +1,96 @@
+# New ports collection makefile for: OpenSSH-askpass
+# Version required: 1.2.2
+# Date created: 27 February 2000
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= X11/xc/programs/ssh-askpass
+PKGNAME= OpenSSH-askpass-1.2.2
+CATEGORIES= security
+# ${MASTER_SITES} is only for if CVS won't work, period.
+MASTER_SITES= http://www.freebsd.org/~kris/distfiles/
+
+MAINTAINER= kris@FreeBSD.org
+
+USE_IMAKE= yes
+
+.include <bsd.port.pre.mk>
+CAT?= /bin/cat
+SED?= /usr/bin/sed
+DISTFILES!= ${SED} 's:^\(.*\)$$:${PKGNAME}/\1:g' ${FILESDIR}/distfiles
+IGNOREFILES!= ${SED} 's:^\(.*\)$$:${PKGNAME}/\1:g' ${FILESDIR}/ignorefiles
+DISTFILES+= ${IGNOREFILES}
+
+CVS_CMD?= cvs -z3
+CVS_DATE= Sun Feb 27 22:21:56 PST 2000
+CVS_DATE_!= ${ECHO} -n "${CVS_DATE}" | ${SED} 's/[ \t:]/_/g'
+CVS_SITES= anoncvs@anoncvs1.ca.openbsd.org:/cvs \
+ :pserver:anoncvs@anoncvs1.usa.openbsd.org:/cvs
+STAMPFILE= ${DISTDIR}/${PKGNAME}/.stamp
+WRKSRC= ${WRKDIR}/ssh-askpass
+
+do-fetch:
+ @if [ ! -e ${STAMPFILE} ] || \
+ [ "X${CVS_DATE}" != "X$$(${CAT} ${STAMPFILE})" ]; then \
+ if [ -e ${DISTDIR}/${PKGNAME}.${CVS_DATE_}.tar.gz ]; then \
+ cd ${DISTDIR}; \
+ ${TAR} xfz ${PKGNAME}.${CVS_DATE_}.tar.gz \
+ ${DISTFILES}; \
+ ${ECHO} -n "${CVS_DATE}" > ${STAMPFILE}; \
+ exit; \
+ fi; \
+ unset CVS_RSH CVS_SERVER || ${TRUE}; \
+ if [ -n "${PORTS_CVS_RSH}" ]; then \
+ export CVS_RSH="${PORTS_CVS_RSH}"; \
+ fi; \
+ ${MKDIR} ${DISTDIR}/${PKGNAME} && \
+ cd ${DISTDIR}/${PKGNAME}; \
+ for CVS_SITE in ${CVS_SITES}; do \
+ ${ECHO_MSG} ">> Attempting to CVS checkout from $${CVS_SITE}."; \
+ if ${CVS_CMD} -d $${CVS_SITE} co -D "${CVS_DATE}" \
+ ${DISTNAME}; then \
+ ${ECHO} -n "${CVS_DATE}" > ${STAMPFILE}; \
+ exit; \
+ fi \
+ done; \
+ ${ECHO_MSG} ">> Couldn't CVS checkout ${PKGNAME}. Please try to retrieve"; \
+ ${ECHO_MSG} ">> a snapshot with \"make fetchsrctarball\" and try again."; \
+ exit 1; \
+ fi
+
+makesrctarball: fetch
+ @cd ${DISTDIR}; \
+ ${ECHO_MSG} ">> Creating source tarball in ${DISTDIR}"; \
+ ${ECHO_MSG} ">> \"${PKGNAME}.${CVS_DATE_}.tar.gz\"."; \
+ ${TAR} cfz ${PKGNAME}.${CVS_DATE_}.tar.gz ${PKGNAME}
+
+fetchsrctarball:
+ @cd ${DISTDIR}; \
+ file=${PKGNAME}.${CVS_DATE_}.tar.gz; \
+ if [ -e $$file ]; then \
+ exit; \
+ fi; \
+ ${ECHO_MSG} ">> $$file doesn't seem to exist on this system."; \
+ for site in ${MASTER_SITES}; do \
+ ${ECHO_MSG} ">> Attempting to fetch from $${site}."; \
+ if ${SETENV} ${FETCH_ENV} ${FETCH_CMD} ${FETCH_BEFORE_ARGS} \
+ $${site}$${file}; then \
+ exit; \
+ fi; \
+ done; \
+ ${ECHO_MSG} ">> Couldn't fetch $$file."; \
+ ${ECHO_MSG} ">> Please try to retrieve this file manually into"; \
+ ${ECHO_MSG} ">> ${_DISTDIR} and try again."; \
+ exit 1
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} -r ${DISTDIR}/${PKGNAME}/${DISTNAME} ${WRKDIR}
+
+pre-install:
+ ${MKDIR} ${PREFIX}/share/doc/ssh-askpass
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ssh-askpass/
+
+.include <bsd.port.post.mk>
diff --git a/security/openssh-askpass/distinfo b/security/openssh-askpass/distinfo
new file mode 100644
index 000000000000..7fbd2292a9ad
--- /dev/null
+++ b/security/openssh-askpass/distinfo
@@ -0,0 +1,32 @@
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/ChangeLog) = 53ece14647acc52874a3f90474fae9ce
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/Imakefile) = 089eb314fcf3d74a01f67735fdc75c05
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/README) = 4a0a2e8ca1b8f851cf4a125b978e47fc
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/SshAskpass-1337.ad) = 34db37f03b3129cdca66a39d97f8483a
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/SshAskpass-NeXTish.ad) = 38a240d537853524422a590b8c96aff6
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/SshAskpass-default.ad) = 6a811cbe8e45126d66fc4eb52bbdd357
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/SshAskpass-green.ad) = b50b5bb6b98ecf7fbe426d56188535c3
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/SshAskpass-motif.ad) = af34ef2ece59729d282279ec5bcb876b
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/drawing.c) = 053370e9b52b46da44e3d3e114a4b5a0
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/drawing.h) = f59e9378776269bee853da12448864c4
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/dynlist.c) = da50268e1222c8b2bed45ab1170be2cf
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/dynlist.h) = 722db816bbd28cb0cb088baf11fdbde6
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/resources.c) = c3eb9c5e2633635006cb6b1c6ef1e03a
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/resources.h) = 5f68be1b675d27ce2add143238f57d2a
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/x11-ssh-askpass.c) = 9f635507ad5344a985e56a73e5fec7a1
+MD5 (OpenSSH-askpass-1.2.2/X11/xc/programs/ssh-askpass/x11-ssh-askpass.h) = fffc85408cda906ae1f0149bdc8275ff
+MD5 (OpenSSH-askpass-1.2.2/./X11/CVS/Root) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/CVS/Repository) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/CVS/Entries) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/CVS/Entries.Static) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/CVS/Root) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/CVS/Repository) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/CVS/Entries) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/CVS/Entries.Static) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/CVS/Root) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/CVS/Repository) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/CVS/Entries) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/CVS/Entries.Static) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/ssh-askpass/CVS/Root) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/ssh-askpass/CVS/Repository) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/ssh-askpass/CVS/Entries) = IGNORE
+MD5 (OpenSSH-askpass-1.2.2/./X11/xc/programs/ssh-askpass/CVS/Tag) = IGNORE
diff --git a/security/openssh-askpass/files/distfiles b/security/openssh-askpass/files/distfiles
new file mode 100644
index 000000000000..872fddaec159
--- /dev/null
+++ b/security/openssh-askpass/files/distfiles
@@ -0,0 +1,16 @@
+X11/xc/programs/ssh-askpass/ChangeLog
+X11/xc/programs/ssh-askpass/Imakefile
+X11/xc/programs/ssh-askpass/README
+X11/xc/programs/ssh-askpass/SshAskpass-1337.ad
+X11/xc/programs/ssh-askpass/SshAskpass-NeXTish.ad
+X11/xc/programs/ssh-askpass/SshAskpass-default.ad
+X11/xc/programs/ssh-askpass/SshAskpass-green.ad
+X11/xc/programs/ssh-askpass/SshAskpass-motif.ad
+X11/xc/programs/ssh-askpass/drawing.c
+X11/xc/programs/ssh-askpass/drawing.h
+X11/xc/programs/ssh-askpass/dynlist.c
+X11/xc/programs/ssh-askpass/dynlist.h
+X11/xc/programs/ssh-askpass/resources.c
+X11/xc/programs/ssh-askpass/resources.h
+X11/xc/programs/ssh-askpass/x11-ssh-askpass.c
+X11/xc/programs/ssh-askpass/x11-ssh-askpass.h
diff --git a/security/openssh-askpass/files/ignorefiles b/security/openssh-askpass/files/ignorefiles
new file mode 100644
index 000000000000..82a66b1b2812
--- /dev/null
+++ b/security/openssh-askpass/files/ignorefiles
@@ -0,0 +1,16 @@
+./X11/CVS/Root
+./X11/CVS/Repository
+./X11/CVS/Entries
+./X11/CVS/Entries.Static
+./X11/xc/CVS/Root
+./X11/xc/CVS/Repository
+./X11/xc/CVS/Entries
+./X11/xc/CVS/Entries.Static
+./X11/xc/programs/CVS/Root
+./X11/xc/programs/CVS/Repository
+./X11/xc/programs/CVS/Entries
+./X11/xc/programs/CVS/Entries.Static
+./X11/xc/programs/ssh-askpass/CVS/Root
+./X11/xc/programs/ssh-askpass/CVS/Repository
+./X11/xc/programs/ssh-askpass/CVS/Entries
+./X11/xc/programs/ssh-askpass/CVS/Tag
diff --git a/security/openssh-askpass/pkg-comment b/security/openssh-askpass/pkg-comment
new file mode 100644
index 000000000000..eae0c3f6e82a
--- /dev/null
+++ b/security/openssh-askpass/pkg-comment
@@ -0,0 +1 @@
+Graphical password applet for entering SSH passphrase
diff --git a/security/openssh-askpass/pkg-descr b/security/openssh-askpass/pkg-descr
new file mode 100644
index 000000000000..80b856af5f60
--- /dev/null
+++ b/security/openssh-askpass/pkg-descr
@@ -0,0 +1,8 @@
+ssh-askpass is a small applet intended for use in conjunction with
+OpenSSH. It pops up a window and requests the user input their SSH
+passphrase. It is not designed to be executed directly, but to be called
+by OpenSSH's ssh-add(1) utility. If no controlling terminal is found (e.g.
+ssh-add is called from the .xinitrc as part of the X login process), and
+DISPLAY is set, ssh-add will spawn ssh-askpass to request the password.
+
+WWW: http://www.openssh.com/
diff --git a/security/openssh-askpass/pkg-plist b/security/openssh-askpass/pkg-plist
new file mode 100644
index 000000000000..8346d06c5003
--- /dev/null
+++ b/security/openssh-askpass/pkg-plist
@@ -0,0 +1,4 @@
+bin/ssh-askpass
+lib/X11/app-defaults/SshAskpass
+share/doc/ssh-askpass/README
+@dirrm share/doc/ssh-askpass