aboutsummaryrefslogtreecommitdiff
path: root/security/openssl-devel
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-04-16 17:51:39 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-04-16 17:51:39 +0000
commit3f8f6c7b36c5cdb11f7c0bea1edc566f58842b44 (patch)
tree4db970473fac6cff581d55279a3f8c4ba669bd12 /security/openssl-devel
parent23b3e26b1edfe66ee45090327251f2a73607f451 (diff)
downloadports-3f8f6c7b36c5cdb11f7c0bea1edc566f58842b44.tar.gz
ports-3f8f6c7b36c5cdb11f7c0bea1edc566f58842b44.zip
security/openssl-devel: Security update for CVE-2018-0737
MFH: 2018Q2 Security: 8f353420-4197-11e8-8777-b499baebfeaf
Notes
Notes: svn path=/head/; revision=467499
Diffstat (limited to 'security/openssl-devel')
-rw-r--r--security/openssl-devel/Makefile1
-rw-r--r--security/openssl-devel/files/patch-CVE-2018-703727
2 files changed, 28 insertions, 0 deletions
diff --git a/security/openssl-devel/Makefile b/security/openssl-devel/Makefile
index dba10ca0bf7b..ce93f5133fdc 100644
--- a/security/openssl-devel/Makefile
+++ b/security/openssl-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openssl
PORTVERSION= 1.1.0h
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
diff --git a/security/openssl-devel/files/patch-CVE-2018-7037 b/security/openssl-devel/files/patch-CVE-2018-7037
new file mode 100644
index 000000000000..fb2c5a176031
--- /dev/null
+++ b/security/openssl-devel/files/patch-CVE-2018-7037
@@ -0,0 +1,27 @@
+From 6939eab03a6e23d2bd2c3f5e34fe1d48e542e787 Mon Sep 17 00:00:00 2001
+From: Billy Brumley <bbrumley@gmail.com>
+Date: Wed, 11 Apr 2018 10:10:58 +0300
+Subject: [PATCH] RSA key generation: ensure BN_mod_inverse and BN_mod_exp_mont
+ both get called with BN_FLG_CONSTTIME flag set.
+
+CVE-2018-0737
+
+Reviewed-by: Rich Salz <rsalz@openssl.org>
+Reviewed-by: Matt Caswell <matt@openssl.org>
+---
+ crypto/rsa/rsa_gen.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/crypto/rsa/rsa_gen.c b/crypto/rsa/rsa_gen.c
+index 9af43e05863..79f77e3eafd 100644
+--- crypto/rsa/rsa_gen.c.orig
++++ crypto/rsa/rsa_gen.c
+@@ -89,6 +89,8 @@ static int rsa_builtin_keygen(RSA *rsa, int bits, BIGNUM *e_value,
+ if (BN_copy(rsa->e, e_value) == NULL)
+ goto err;
+
++ BN_set_flags(rsa->p, BN_FLG_CONSTTIME);
++ BN_set_flags(rsa->q, BN_FLG_CONSTTIME);
+ BN_set_flags(r2, BN_FLG_CONSTTIME);
+ /* generate p and q */
+ for (;;) {