aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-03-27 14:53:51 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-03-27 14:53:51 +0000
commit7e46d11ac90474a7a2eeaac55a7419ae681883b7 (patch)
treed724e334a9bc6300fe90cac269ca02aa8b6abc1d /security/openssl
parent8389a17fe2f714c7d19d27d4f31dae13007b0b17 (diff)
downloadports-7e46d11ac90474a7a2eeaac55a7419ae681883b7.tar.gz
ports-7e46d11ac90474a7a2eeaac55a7419ae681883b7.zip
securit/openssl: Security update to 1.0.2o
MFH: 2018Q1 Security: b7cff5a9-31cc-11e8-8f07-b499baebfeaf
Notes
Notes: svn path=/head/; revision=465710
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/distinfo14
-rw-r--r--security/openssl/files/patch-ssl_fatalerrtest.c48
3 files changed, 4 insertions, 60 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 378eae645722..ab48273835d5 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openssl
-PORTVERSION= 1.0.2n
+PORTVERSION= 1.0.2o
PORTEPOCH= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index b7a9e36a64be..07261bcdaa78 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,11 +1,3 @@
-TIMESTAMP = 1512655797
-SHA256 (openssl-1.0.2/openssl-1.0.2n.tar.gz) = 370babb75f278c39e0c50e8c4e7493bc0f18db6867478341a832a982fd15a8fe
-SIZE (openssl-1.0.2/openssl-1.0.2n.tar.gz) = 5375802
-SHA256 (openssl-1.0.2/1001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESHOT-and-set-.patch) = 2eddcb7ab342285cb637ce6b6be143cca835f449f35dd9bb8c7b9167ba2117a7
-SIZE (openssl-1.0.2/1001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESHOT-and-set-.patch) = 3717
-SHA256 (openssl-1.0.2/1002-backport-changes-from-upstream-padlock-module.patch) = aee88a24622ce9d71e38deeb874e58435dcf8ff5690f56194f0e4a00fb09b260
-SIZE (openssl-1.0.2/1002-backport-changes-from-upstream-padlock-module.patch) = 5770
-SHA256 (openssl-1.0.2/1003-engines-e_padlock-implement-sha1-sha224-sha256-accel.patch) = c10b8aaf56a4f4f79ca195fc587e0bb533f643e777d7a3e6fb0350399a6060ea
-SIZE (openssl-1.0.2/1003-engines-e_padlock-implement-sha1-sha224-sha256-accel.patch) = 20935
-SHA256 (openssl-1.0.2/1004-crypto-engine-autoload-padlock-dynamic-engine.patch) = 97eb4411d0fc0890e94bc7c2d682f68b71135da782af769ca73914b37da2b1fd
-SIZE (openssl-1.0.2/1004-crypto-engine-autoload-padlock-dynamic-engine.patch) = 832
+TIMESTAMP = 1522160096
+SHA256 (openssl-1.0.2/openssl-1.0.2o.tar.gz) = ec3f5c9714ba0fd45cb4e087301eb1336c317e0d20b575a125050470e8089e4d
+SIZE (openssl-1.0.2/openssl-1.0.2o.tar.gz) = 5329472
diff --git a/security/openssl/files/patch-ssl_fatalerrtest.c b/security/openssl/files/patch-ssl_fatalerrtest.c
deleted file mode 100644
index 91765d65c4b5..000000000000
--- a/security/openssl/files/patch-ssl_fatalerrtest.c
+++ /dev/null
@@ -1,48 +0,0 @@
-From a4597f079bf2662e06d505538f83b6b610c41c7c Mon Sep 17 00:00:00 2001
-From: Matt Caswell <matt@openssl.org>
-Date: Thu, 7 Dec 2017 14:40:49 +0000
-Subject: [PATCH] Fix initialisation in fatalerrtest
-
----
- ssl/fatalerrtest.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/ssl/fatalerrtest.c b/ssl/fatalerrtest.c
-index 0288c33fa2e..749bc3697ea 100644
---- ssl/fatalerrtest.c.orig
-+++ ssl/fatalerrtest.c
-@@ -13,8 +13,8 @@
-
- int main(int argc, char *argv[])
- {
-- SSL_CTX *sctx, *cctx;
-- SSL *sssl, *cssl;
-+ SSL_CTX *sctx = NULL, *cctx = NULL;
-+ SSL *sssl = NULL, *cssl = NULL;
- const char *msg = "Dummy";
- BIO *err = NULL, *wbio = NULL;
- int ret = 1, len;
-From b24e0573c6838e8d726fb16d558c562ce4e8f025 Mon Sep 17 00:00:00 2001
-From: Matt Caswell <matt@openssl.org>
-Date: Thu, 7 Dec 2017 14:41:21 +0000
-Subject: [PATCH] Fix the buffer sizing in the fatalerrtest
-
-Fixes #4865
----
- ssl/fatalerrtest.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ssl/fatalerrtest.c b/ssl/fatalerrtest.c
-index 749bc3697ea..f9d66e27b30 100644
---- ssl/fatalerrtest.c.orig
-+++ ssl/fatalerrtest.c
-@@ -76,7 +76,7 @@ int main(int argc, char *argv[])
- }
-
- /* SSL_read()/SSL_write should fail because of a previous fatal error */
-- if ((len = SSL_read(sssl, buf, sizeof(buf - 1))) > 0) {
-+ if ((len = SSL_read(sssl, buf, sizeof(buf) - 1)) > 0) {
- buf[len] = '\0';
- printf("Unexpected success reading data: %s\n", buf);
- goto err;
-