aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-06-12 13:43:28 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-06-12 13:43:28 +0000
commitc456ea56640a8eb1e903cba5c6e88a067ebe48f8 (patch)
tree5c5f3675976e7d8fec0a5498a0b3861fd3fadc2f /security/openssl
parent7cb11fade70796422848f32e68953b4ca42e0e0a (diff)
downloadports-c456ea56640a8eb1e903cba5c6e88a067ebe48f8.tar.gz
ports-c456ea56640a8eb1e903cba5c6e88a067ebe48f8.zip
security/openssl: Actually add patch file
MFH: 2018Q2 Security: c82ecac5-6e3f-11e8-8777-b499baebfeaf
Notes
Notes: svn path=/head/; revision=472245
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-CVE-2018-073239
2 files changed, 40 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index b8a52c4237d6..98e074931c56 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssl
PORTVERSION= 1.0.2o
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
diff --git a/security/openssl/files/patch-CVE-2018-0732 b/security/openssl/files/patch-CVE-2018-0732
new file mode 100644
index 000000000000..f6ef0008152a
--- /dev/null
+++ b/security/openssl/files/patch-CVE-2018-0732
@@ -0,0 +1,39 @@
+From 3984ef0b72831da8b3ece4745cac4f8575b19098 Mon Sep 17 00:00:00 2001
+From: Guido Vranken <guidovranken@gmail.com>
+Date: Mon, 11 Jun 2018 19:38:54 +0200
+Subject: [PATCH] Reject excessively large primes in DH key generation.
+
+CVE-2018-0732
+
+Signed-off-by: Guido Vranken <guidovranken@gmail.com>
+
+(cherry picked from commit 91f7361f47b082ae61ffe1a7b17bb2adf213c7fe)
+
+Reviewed-by: Tim Hudson <tjh@openssl.org>
+Reviewed-by: Matt Caswell <matt@openssl.org>
+(Merged from https://github.com/openssl/openssl/pull/6457)
+---
+ crypto/dh/dh_key.c | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/crypto/dh/dh_key.c b/crypto/dh/dh_key.c
+index 387558f1467..f235e0d682b 100644
+--- crypto/dh/dh_key.c.orig
++++ crypto/dh/dh_key.c
+@@ -130,10 +130,15 @@ static int generate_key(DH *dh)
+ int ok = 0;
+ int generate_new_key = 0;
+ unsigned l;
+- BN_CTX *ctx;
++ BN_CTX *ctx = NULL;
+ BN_MONT_CTX *mont = NULL;
+ BIGNUM *pub_key = NULL, *priv_key = NULL;
+
++ if (BN_num_bits(dh->p) > OPENSSL_DH_MAX_MODULUS_BITS) {
++ DHerr(DH_F_GENERATE_KEY, DH_R_MODULUS_TOO_LARGE);
++ return 0;
++ }
++
+ ctx = BN_CTX_new();
+ if (ctx == NULL)
+ goto err;