aboutsummaryrefslogtreecommitdiff
path: root/security/openssl_tpm_engine/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-07-25 15:30:11 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-07-25 15:30:11 +0000
commita78adc05c203d108e767e3b660d99529b5b61968 (patch)
tree6919857f0a7b29debbef6da1d37487531fdd1112 /security/openssl_tpm_engine/Makefile
parent7dcaf2769263791d2dc18696da67a84d67d40305 (diff)
downloadports-a78adc05c203d108e767e3b660d99529b5b61968.tar.gz
ports-a78adc05c203d108e767e3b660d99529b5b61968.zip
Notes
Diffstat (limited to 'security/openssl_tpm_engine/Makefile')
-rw-r--r--security/openssl_tpm_engine/Makefile40
1 files changed, 20 insertions, 20 deletions
diff --git a/security/openssl_tpm_engine/Makefile b/security/openssl_tpm_engine/Makefile
index 804365bc4de7..e1af8e4d27bf 100644
--- a/security/openssl_tpm_engine/Makefile
+++ b/security/openssl_tpm_engine/Makefile
@@ -1,42 +1,42 @@
-# New ports collection makefile for: openssl_tpm_engine
-# Date created: 18 Sep 2007
-# Whom: Sebastian Schuetz <sschuetz@fhm.edu>
-#
+# Created by: Sebastian Schuetz <sschuetz@fhm.edu>
# $FreeBSD$
-#
PORTNAME= openssl_tpm_engine
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 0.4.2
CATEGORIES= security
MASTER_SITES= SF/trousers/OpenSSL%20TPM%20Engine/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= OpenSSL TPM engine
+LICENSE= GPLv2
+
RUN_DEPENDS= ${LOCALBASE}/sbin/tcsd:${PORTSDIR}/security/trousers
-LIB_DEPENDS= tspi.2:${PORTSDIR}/security/trousers
+LIB_DEPENDS= tspi:${PORTSDIR}/security/trousers
-USE_GMAKE= YES
-GNU_CONFIGURE= YES
-MAKE_JOBS_SAFE= YES
+USES= gmake
USE_AUTOTOOLS= autoconf libtool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-
+CFLAGS+= -I${LOCALBASE}/include
SUB_FILES= pkg-message
+PORTEXAMPLES= openssl.cnf.sample
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE
+OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFAULT=EXAMPLES
-.include <bsd.port.pre.mk>
-CFLAGS+= -I${LOCALBASE}/include
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/openssl.cnf.sample
post-install:
- @[ -d ${EXAMPLESDIR} ] || ${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/openssl.cnf.sample ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/openssl.cnf.sample ${EXAMPLESDIR}
+.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>