aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-auth-script
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-06 06:24:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-06 06:24:17 +0000
commitbb61ffd5e57adfdf87196a756a9cf20b26a00b26 (patch)
tree746aede527ba8a24052c18abf97915f4658fb91b /security/openvpn-auth-script
parent3b91b7d9756997c6d1dd702a2d70f721fc0c4732 (diff)
Notes
Diffstat (limited to 'security/openvpn-auth-script')
-rw-r--r--security/openvpn-auth-script/Makefile24
-rw-r--r--security/openvpn-auth-script/distinfo3
-rw-r--r--security/openvpn-auth-script/pkg-descr6
3 files changed, 33 insertions, 0 deletions
diff --git a/security/openvpn-auth-script/Makefile b/security/openvpn-auth-script/Makefile
new file mode 100644
index 000000000000..2a9af7a091db
--- /dev/null
+++ b/security/openvpn-auth-script/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= openvpn-auth-script
+DISTVERSION= 1.0.0.3
+CATEGORIES= security net
+
+MAINTAINER= pdemon@gmail.com
+COMMENT= Generic script-based deferred auth plugin for OpenVPN
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/openvpn-plugin.h:security/openvpn
+
+USES= gmake localbase
+USE_GITHUB= yes
+GH_ACCOUNT= pdemonaco
+
+PLIST_FILES= lib/openvpn/plugins/openvpn-plugin-auth-script.so
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/openvpn/plugins/openvpn-plugin-auth-script.so
+
+.include <bsd.port.mk>
diff --git a/security/openvpn-auth-script/distinfo b/security/openvpn-auth-script/distinfo
new file mode 100644
index 000000000000..327d6657604b
--- /dev/null
+++ b/security/openvpn-auth-script/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520619829
+SHA256 (pdemonaco-openvpn-auth-script-1.0.0.3_GH0.tar.gz) = b9c7c484c837300fbc6bed12d0103a59f1a5c10f1afe9e5af1576517f32c3c07
+SIZE (pdemonaco-openvpn-auth-script-1.0.0.3_GH0.tar.gz) = 8996
diff --git a/security/openvpn-auth-script/pkg-descr b/security/openvpn-auth-script/pkg-descr
new file mode 100644
index 000000000000..3245bc65e880
--- /dev/null
+++ b/security/openvpn-auth-script/pkg-descr
@@ -0,0 +1,6 @@
+Implements the deferred authentication handler defined by the OpenVPN standard
+interface. By using this plugin instead of auth-user-pass-verify, slow
+authentication methods like push-based multi factor nolonger cause other active
+VPN sessions to hang.
+
+WWW: https://github.com/pdemonaco/auth-script-openvpn