aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-19 18:48:34 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-19 18:48:34 +0000
commit0f64e52705d69159d709754fd9a48a6623a6cd96 (patch)
tree59b40faa77773bf366e51b65a76c5fb31234cb4d /security/openvpn/Makefile
parentc8adfc87dbf37ec4b430fbd74910f1126323f9f4 (diff)
downloadports-0f64e52705d69159d709754fd9a48a6623a6cd96.tar.gz
ports-0f64e52705d69159d709754fd9a48a6623a6cd96.zip
Notes
Diffstat (limited to 'security/openvpn/Makefile')
-rw-r--r--security/openvpn/Makefile32
1 files changed, 18 insertions, 14 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index b39638afd95c..aa1e99cb11af 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -1,21 +1,18 @@
# New ports collection makefile for: openvpn
# Date created: 2002-06-23
-# Whom: Matthias Andree <matthias.andree@web.de>
+# Whom: Matthias Andree <matthias.andree@gmx.de>
#
# $FreeBSD$
#
PORTNAME= openvpn
-DISTVERSION= 2.0
-PORTREVISION= 3
+DISTVERSION= 2.0.1
CATEGORIES= security
MASTER_SITES= http://openvpn.net/release/
MAINTAINER= matthias.andree@gmx.de
COMMENT= Secure IP/Ethernet tunnel daemon
-LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
-
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -26,25 +23,31 @@ MAN8= openvpn.8
OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off
+USE_RC_SUBR= openvpn.sh
+
+SUB_FILES= pkg-message
+
.include <bsd.port.pre.mk>
+# NOTE: there is no way to explicitly specify the LZO version to OpenVPN,
+# if LZO2 and LZO1 are installed, OpenVPN will pick LZO2.
+# So depend on LZO1 only if it's already there and LZO2 isn't.
+# PACKAGE_BUILDING will also force LZO2.
+.if exists(${LOCALBASE}/lib/liblzo2.so.2) || !exists(${LOCALBASE}/lib/liblzo.so.1) || defined(PACKAGE_BUILDING)
+LIB_DEPENDS= lzo2.2:${PORTSDIR}/archivers/lzo2
+.else
+LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
+.endif
+
.if defined(WITH_PW_SAVE)
CONFIGURE_ARGS+= --enable-password-save
.endif
# self-tests here
post-build:
- ( set -e ; cd ${WRKSRC} && \
- ./openvpn --genkey --secret key && \
- ./openvpn --test-crypto --secret key && ${RM} key )
- ( set -e ; cd ${WRKSRC} && { \
- ./openvpn --config sample-config-files/loopback-server & \
- ./openvpn --config sample-config-files/loopback-client ; \
- wait ; })
+ cd ${WRKSRC} && ${MAKE} check
post-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/openvpn.sh.sample \
- ${PREFIX}/etc/rc.d/openvpn.sh.sample
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
@@ -56,5 +59,6 @@ post-install:
| ${GREP} -v easy-rsa/Windows \
| ${CPIO} -pdmu ${DOCSDIR} )
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>