aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-11-09 22:06:26 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-11-09 22:06:26 +0000
commit8cf2ecce413c3264ea3b9d3217949807832d63d0 (patch)
treee3e984ddba5444662f2a644d4057f448033ee576 /security/openvpn/Makefile
parentd98043fc3781a9948051408ec7bc9cc91bbfb744 (diff)
downloadports-8cf2ecce413c3264ea3b9d3217949807832d63d0.tar.gz
ports-8cf2ecce413c3264ea3b9d3217949807832d63d0.zip
Notes
Diffstat (limited to 'security/openvpn/Makefile')
-rw-r--r--security/openvpn/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 3368a096b68a..b16360401078 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openvpn
DISTVERSION= 2.3.13
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= http://swupdate.openvpn.net/community/releases/ \
http://build.openvpn.net/downloads/releases/
@@ -31,8 +32,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -DPLUGIN_LIBDIR=\\\"${PREFIX}/lib/openvpn/plugins\\\"
OPTIONS_DEFINE= PKCS11 EASYRSA DOCS EXAMPLES X509ALTUSERNAME \
- TUNNELBLICK TEST
-OPTIONS_DEFAULT= EASYRSA OPENSSL TEST
+ TUNNELBLICK TEST FIXSUBNET
+OPTIONS_DEFAULT= EASYRSA OPENSSL TEST FIXSUBNET
OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= OPENSSL POLARSSL
# The following feature is always enabled since 2.3.9 and no longer optional.
@@ -42,6 +43,7 @@ EASYRSA_DESC= Install security/easy-rsa RSA helper package
POLARSSL_DESC= SSL/TLS via mbedTLS 1.3.X (not 2.x)
TUNNELBLICK_DESC= Tunnelblick XOR scramble patch (READ HELP!)
X509ALTUSERNAME_DESC= Enable --x509-username-field (OpenSSL only)
+FIXSUBNET_DESC= Enable 'topology subnet' fix (experimental)
EASYRSA_RUN_DEPENDS= easy-rsa>=0:security/easy-rsa
@@ -50,6 +52,8 @@ PKCS11_CONFIGURE_ENABLE= pkcs11
TUNNELBLICK_EXTRA_PATCHES= ${FILESDIR}/extra-tunnelblick-openvpn_xorpatch
+FIXSUBNET_EXTRA_PATCHES= ${FILESDIR}/extra-patch-fix-subnet
+
X509ALTUSERNAME_CONFIGURE_ENABLE= x509-alt-username
X509ALTUSERNAME_PREVENTS= POLARSSL