aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-07-07 00:16:57 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-07-07 00:16:57 +0000
commitcf8ca0757dc8878622cb5c8d5ac02bdfefb1c3d6 (patch)
tree190d0d2960de2af3eb2c34b0871e024e52eaa746 /security/openvpn/Makefile
parentb4e9ab0bdd70d5003e5b70fce243cd7bea2ad55b (diff)
downloadports-cf8ca0757dc8878622cb5c8d5ac02bdfefb1c3d6.tar.gz
ports-cf8ca0757dc8878622cb5c8d5ac02bdfefb1c3d6.zip
Update to upstream release 2.2.1.
NOTE: the easy-rsa/2.0 openssl.cnf file has been removed and replaced by an openssl-0.9.8.cnf and an openssl-1.0.0.cnf file. Changelog URL: http://openvpn.net/index.php/open-source/documentation/change-log/425-changelog-for-openvpn-22.html
Notes
Notes: svn path=/head/; revision=277199
Diffstat (limited to 'security/openvpn/Makefile')
-rw-r--r--security/openvpn/Makefile29
1 files changed, 16 insertions, 13 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 66504ff9d6ac..b00fa188895e 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openvpn
-DISTVERSION= 2.2.0
+DISTVERSION= 2.2.1
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
@@ -44,18 +44,6 @@ SUB_LIST+= OSVERSION=${OSVERSION}
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
-pre-configure:
-.ifdef (LOG_OPENVPN)
- @${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
-.else
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " LOG_OPENVPN={Valid syslog facility, default LOG_DAEMON}"
- @${ECHO} " EXAMPLE: make LOG_OPENVPN=LOG_DAEMON"
- @${ECHO} ""
-.endif
-
LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
.if defined(WITH_PW_SAVE)
@@ -68,6 +56,9 @@ LIB_DEPENDS+= pkcs11-helper.1:${PORTSDIR}/security/pkcs11-helper
CONFIGURE_ARGS+= --disable-pkcs11
.endif
+post-extract:
+ @${RM} ${WRKSRC}/easy-rsa/2.0/openssl-1.0.0.cnf-old-copy
+
post-patch:
@${FIND} ${WRKSRC}/easy-rsa/?.0 -type f \
-exec ${REINPLACE_CMD} -e 's;#!/bin/bash;#!/bin/sh;' \
@@ -76,6 +67,18 @@ post-patch:
-exec ${REINPLACE_CMD} -e 's;gcc;${CC};g' '{}' +
@${FIND} ${WRKSRC} \( -name \*.orig -o -name \*.bak \) -delete
+pre-configure:
+.ifdef (LOG_OPENVPN)
+ @${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
+.else
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " LOG_OPENVPN={Valid syslog facility, default LOG_DAEMON}"
+ @${ECHO} " EXAMPLE: make LOG_OPENVPN=LOG_DAEMON"
+ @${ECHO} ""
+.endif
+
post-build:
cd ${WRKSRC}/plugin/down-root && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS}
cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 ${CFLAGS} -fPIC -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam