aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-08-27 09:32:30 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-08-27 09:32:30 +0000
commit2efda235d0dea106587ea83997bc4e3d847102c1 (patch)
tree2341419924c789c0378efa83c645b80b0b6ad94e /security/openvpn
parent005972049e8fe521e28580bd15fa6037dc962b6a (diff)
downloadports-2efda235d0dea106587ea83997bc4e3d847102c1.tar.gz
ports-2efda235d0dea106587ea83997bc4e3d847102c1.zip
Make self-test the TEST option, support make test. Enabled by default.
NB: This is a critical port with many users, and the test is low on resources, it takes two minutes idling, waiting for timers to expire. Replace former ".if ... post-build:" by "post-build-TEST-on: test". Replace former post-build by "TEST_TARGET=check". Add a temporary (9 months or so-ish) compatibility wrapper to move people from the prior port-specific WITHOUT_CHECK to WITHOUT=TEST or OPTIONS_UNSET=TEST. Uses WARNING+= to make user aware of the change. While here, shorten the POLARSSL_DESC help message. Requested by: brnrd@ Differential Revision: D7507 (sort-of)
Notes
Notes: svn path=/head/; revision=420966
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index db62f6b01c79..b806a6b4ac5d 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -21,7 +21,7 @@ SHEBANG_FILES= sample/sample-scripts/verify-cn \
sample/sample-scripts/auth-pam.pl \
sample/sample-scripts/ucn.pl
# avoid picking up CMAKE, we don't have cmocka anyways.
-CONFIGURE_ARGS+= CMAKE=""
+CONFIGURE_ENV+= ac_cv_prog_CMAKE= CMAKE=
# let OpenVPN's configure script pick up the requisite libraries,
# but do not break the plugin build if an older version is installed
@@ -32,15 +32,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -DPLUGIN_LIBDIR=\\\"${PREFIX}/lib/openvpn/plugins\\\"
OPTIONS_DEFINE= PKCS11 EASYRSA DOCS EXAMPLES X509ALTUSERNAME \
- TUNNELBLICK
-OPTIONS_DEFAULT= EASYRSA OPENSSL
+ TUNNELBLICK TEST
+OPTIONS_DEFAULT= EASYRSA OPENSSL TEST
OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= OPENSSL POLARSSL
# The following feature is always enabled since 2.3.9 and no longer optional.
# PW_SAVE_DESC= Interactive passwords may be read from a file
PKCS11_DESC= Use security/pkcs11-helper
EASYRSA_DESC= Install security/easy-rsa RSA helper package
-POLARSSL_DESC= SSL/TLS via PolarSSL (mbedTLS) 1.3.8+ (not 2.x)
+POLARSSL_DESC= SSL/TLS via mbedTLS 1.3.X (not 2.x)
TUNNELBLICK_DESC= Tunnelblick XOR scramble patch (READ HELP!)
X509ALTUSERNAME_DESC= Enable --x509-username-field (OpenSSL only)
@@ -79,6 +79,14 @@ LIB_DEPENDS+= liblzo2.so:archivers/lzo2
PORTDOCS= *
PORTEXAMPLES= *
+TEST_TARGET= check
+
+# XXX Please remove this compatibility wrapper after 2017Q2 is branched.
+.ifdef(WITHOUT_CHECK)
+WARNING+= "${.CURDIR}: WITHOUT_CHECK is deprecated, please use WITHOUT=TEST or OPTIONS_UNSET=TEST."
+WITHOUT+= TEST
+.endif
+
pre-configure:
.ifdef (LOG_OPENVPN)
@${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
@@ -96,12 +104,7 @@ post-configure:
${WRKSRC}/src/plugins/auth-pam/Makefile \
${WRKSRC}/src/plugins/down-root/Makefile
-.if !defined(WITHOUT_CHECK)
-post-build:
- @# self-tests here
- @${ECHO} ; ${ECHO} "### Note that you can skip these lengthy selftests with WITHOUT_CHECK=yes ###" ; ${ECHO}
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} check
-.endif
+post-build-TEST-on: test
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/openvpn/plugins/openvpn-plugin-auth-pam.so