aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-11-01 12:16:27 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-11-01 12:16:37 +0000
commit89d9e9320aff2d4c61be4c7dfa1b6829717bd034 (patch)
tree3fa2b771b98327442cc1d2465b3cb686bba5f93e /security/openvpn
parent130a5d7e5a66d0feda489e3d9aefd96df696cfbc (diff)
downloadports-89d9e9320aff2d4c61be4c7dfa1b6829717bd034.tar.gz
ports-89d9e9320aff2d4c61be4c7dfa1b6829717bd034.zip
security/openvpn: rearrange Makefile
to portclippy-reported standard ordering
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 8c4bdcae27ac..0c571b012fd6 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -21,9 +21,6 @@ SHEBANG_FILES= sample/sample-scripts/verify-cn \
sample/sample-scripts/auth-pam.pl \
sample/sample-scripts/ucn.pl
-USERS= openvpn
-GROUPS= openvpn
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-strict
# set PLUGIN_LIBDIR so that unqualified plugin paths are found:
@@ -33,6 +30,9 @@ CONFLICTS_INSTALL?= openvpn-2.[!5].* openvpn-devel-[0-9]* openvpn-mbedtls-[0-9]*
SUB_FILES= pkg-message openvpn-client
+USERS= openvpn
+GROUPS= openvpn
+
PORTDOCS= *
PORTEXAMPLES= *
@@ -103,6 +103,13 @@ _tlslibs=libssl libcrypto
CONFIGURE_ARGS+= --enable-comp-stub
.endif
+post-patch:
+ ${REINPLACE_CMD} -E -i '' -e 's/(user|group) nobody/\1 openvpn/' \
+ -e 's/"nobody"( after init)/"openvpn" \1/' \
+ ${WRKSRC}/sample/sample-config-files/*.conf \
+ ${WRKSRC}/sample/sample-config-files/xinetd-*-config \
+ ${WRKSRC}/doc/man-sections/generic-options.rst
+
pre-configure:
.ifdef (LOG_OPENVPN)
@${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
@@ -122,13 +129,6 @@ pre-configure:
@${ECHO} "### --------------------------------------------------------- ###"
.endif
-post-patch:
- ${REINPLACE_CMD} -E -i '' -e 's/(user|group) nobody/\1 openvpn/' \
- -e 's/"nobody"( after init)/"openvpn" \1/' \
- ${WRKSRC}/sample/sample-config-files/*.conf \
- ${WRKSRC}/sample/sample-config-files/xinetd-*-config \
- ${WRKSRC}/doc/man-sections/generic-options.rst
-
post-configure:
${REINPLACE_CMD} '/^CFLAGS =/s/$$/ -fPIC/' \
${WRKSRC}/src/plugins/auth-pam/Makefile \