aboutsummaryrefslogtreecommitdiff
path: root/security/ophcrack
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-03-14 15:47:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-03-14 15:47:59 +0000
commit9578aa4d06ae164efeb0f4d78780141b8209ae34 (patch)
tree7aaa2bc39c95c7526ac364ea65ab9e7c64e3c2cb /security/ophcrack
parent0ebd6ccab2ef4e86d5df9fb10c626c07b9189c4c (diff)
downloadports-9578aa4d06ae164efeb0f4d78780141b8209ae34.tar.gz
ports-9578aa4d06ae164efeb0f4d78780141b8209ae34.zip
Add a port of ophcrack, a Windows password cracker based on rainbow tables,
Notes
Notes: svn path=/head/; revision=209043
Diffstat (limited to 'security/ophcrack')
-rw-r--r--security/ophcrack/Makefile62
-rw-r--r--security/ophcrack/distinfo9
-rw-r--r--security/ophcrack/files/pkg-message.in10
-rw-r--r--security/ophcrack/pkg-descr13
-rw-r--r--security/ophcrack/pkg-plist8
5 files changed, 102 insertions, 0 deletions
diff --git a/security/ophcrack/Makefile b/security/ophcrack/Makefile
new file mode 100644
index 000000000000..ca849b4345b6
--- /dev/null
+++ b/security/ophcrack/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: ophcrack
+# Date created: 14 Mar 2008
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ophcrack
+PORTVERSION= 2.4.1
+CATEGORIES= security
+MASTER_SITES= SF
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} bkhive-${TOOLS_VER}${EXTRACT_SUFX} \
+ samdump2-${TOOLS_VER}${EXTRACT_SUFX}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Windows password cracker based on rainbow tables
+
+USE_GNOME= gtk20
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+SUB_FILES+= pkg-message
+PORTDOCS= *
+MAN1= bkhive.1 samdump2.1
+
+TOOLS_VER= 1.1.1
+
+post-extract:
+ @${REINPLACE_CMD} -e '/^CFLAGS=/d' ${WRKSRC}/${CONFIGURE_SCRIPT}
+# Do not install any Linux binaries: we build and install native ones;
+# mute their banner as well in favor of our nice pkg-message
+ @${REINPLACE_CMD} -e 's/ install-exec-local// ; 605,617d' \
+ ${WRKSRC}/Makefile.in
+# Hint the tools about correct endianness
+ @${REINPLACE_CMD} -e '27s,^,#include <machine/endian.h>,' \
+ ${WRKDIR}/bkhive-${TOOLS_VER}/bkhive.c
+ @${REINPLACE_CMD} -e '34s,^,#include <machine/endian.h>,' \
+ ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2.c
+
+post-build:
+# Build auxiliary tools (useful: e.g., samdump2 is called at runtime)
+ (cd ${WRKDIR}/bkhive-${TOOLS_VER} && ${CC} ${CFLAGS} -o bkhive \
+ hive.c bkhive.c)
+ (cd ${WRKDIR}/samdump2-${TOOLS_VER} && ${CC} ${CFLAGS} -o samdump2 \
+ hive.c samdump2.c -lssl)
+
+post-install:
+# Install auxiliary tools and their manpages
+ ${INSTALL_PROGRAM} ${WRKDIR}/bkhive-${TOOLS_VER}/bkhive \
+ ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2 ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKDIR}/bkhive-${TOOLS_VER}/bkhive.1 \
+ ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2.1 \
+ ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/security/ophcrack/distinfo b/security/ophcrack/distinfo
new file mode 100644
index 000000000000..6deb5659621b
--- /dev/null
+++ b/security/ophcrack/distinfo
@@ -0,0 +1,9 @@
+MD5 (ophcrack-2.4.1.tar.gz) = 9087eb77378bfcf02a843550cd6fc2ec
+SHA256 (ophcrack-2.4.1.tar.gz) = bb7723e2a3a289a16b7c76f1a6ba4b38007a41e675a437b6ae3e115613f7f355
+SIZE (ophcrack-2.4.1.tar.gz) = 171256
+MD5 (bkhive-1.1.1.tar.gz) = bb5e076f3051c60331a7831b6c11719d
+SHA256 (bkhive-1.1.1.tar.gz) = 3f5f85b507d56c09944b394c94551fa27d6fc5ca21ec033e4ebd98ac47417e68
+SIZE (bkhive-1.1.1.tar.gz) = 15985
+MD5 (samdump2-1.1.1.tar.gz) = f8c321594444df2dd3ca5be040ca5097
+SHA256 (samdump2-1.1.1.tar.gz) = 51310babf8f23933a03aba115ae7ac7282d4f16cd6aa96fe3650ff294fb3516e
+SIZE (samdump2-1.1.1.tar.gz) = 18888
diff --git a/security/ophcrack/files/pkg-message.in b/security/ophcrack/files/pkg-message.in
new file mode 100644
index 000000000000..54e46fbaab67
--- /dev/null
+++ b/security/ophcrack/files/pkg-message.in
@@ -0,0 +1,10 @@
+Don't forget to download the tables from
+
+ http://lasecwww.epfl.ch/SSTIC04-10k.zip, or
+ http://lasecwww.epfl.ch/SSTIC04-5k.zip
+
+and install them in %%DATADIR%%/10000 or
+%%DATADIR%%/5000, respectively.
+
+SSTIC04-10k (388MB), for PCs with at least 256MB of RAM.
+SSTIC04-5k (720MB), for PCs with at least 512MB of RAM.
diff --git a/security/ophcrack/pkg-descr b/security/ophcrack/pkg-descr
new file mode 100644
index 000000000000..3e1a9e06cd06
--- /dev/null
+++ b/security/ophcrack/pkg-descr
@@ -0,0 +1,13 @@
+Ophcrack is a Windows password cracker based on a time-memory trade-off
+using rainbow tables. This is a new variant of Hellman's original trade-off,
+with better performance. It recovers 99.9% of alphanumeric passwords in
+seconds. Features:
+
+ - Runs on Windows, Linux, FreeBSD, and Mac OS X (x86)
+ - Cracks LM and NTLM hashes
+ - Free tables available for alphanumeric LM hashes
+ - Loads hashes from local SAM, remote SAM
+ - Loads hashes from encrypted SAM recovered from a Windows partition,
+ Vista included
+
+WWW: http://ophcrack.sourceforge.net/
diff --git a/security/ophcrack/pkg-plist b/security/ophcrack/pkg-plist
new file mode 100644
index 000000000000..33e28ee8dbb2
--- /dev/null
+++ b/security/ophcrack/pkg-plist
@@ -0,0 +1,8 @@
+bin/bkhive
+bin/ophcrack
+bin/samdump2
+%%DATADIR%%/pixmaps/logo_os.xpm
+%%DATADIR%%/pixmaps/os.ico
+%%DATADIR%%/pixmaps/os.xpm
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%