aboutsummaryrefslogtreecommitdiff
path: root/security/p11-kit
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2017-09-03 07:21:13 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2017-09-03 07:21:13 +0000
commit49a0008ddf90af934c4169c5396bda721cb3be10 (patch)
treedfa59f0df015297e1c90b4746fa2dd2a435194ab /security/p11-kit
parent65e92bdc6c5c080a4b0618910cb64949e45123fc (diff)
downloadports-49a0008ddf90af934c4169c5396bda721cb3be10.tar.gz
ports-49a0008ddf90af934c4169c5396bda721cb3be10.zip
security/p11-kit: update to 0.23.8
Include two patches from upstream for: * Fixing build without debug * Adding missing stdint.h include to fix build on FreeBSD 10.x
Notes
Notes: svn path=/head/; revision=449174
Diffstat (limited to 'security/p11-kit')
-rw-r--r--security/p11-kit/Makefile2
-rw-r--r--security/p11-kit/distinfo6
-rw-r--r--security/p11-kit/files/patch-common_compat.c10
-rw-r--r--security/p11-kit/files/patch-common_debug.h13
4 files changed, 27 insertions, 4 deletions
diff --git a/security/p11-kit/Makefile b/security/p11-kit/Makefile
index 960324bc75ab..b70b152e7e10 100644
--- a/security/p11-kit/Makefile
+++ b/security/p11-kit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= p11-kit
-PORTVERSION= 0.23.7
+PORTVERSION= 0.23.8
CATEGORIES= security devel
MASTER_SITES= https://github.com/p11-glue/p11-kit/releases/download/${PORTVERSION}/
diff --git a/security/p11-kit/distinfo b/security/p11-kit/distinfo
index 88f339106323..f458e58879b1 100644
--- a/security/p11-kit/distinfo
+++ b/security/p11-kit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496461827
-SHA256 (p11-kit-0.23.7.tar.gz) = 988e7c86f2641b36702503481292ef0686e6b1c39d80b215699b6dbf1024be41
-SIZE (p11-kit-0.23.7.tar.gz) = 1087009
+TIMESTAMP = 1503207736
+SHA256 (p11-kit-0.23.8.tar.gz) = 4ba134e5fe4b62bcaf7a2d66841767d9d23e875b977bba6939367a9f400b133f
+SIZE (p11-kit-0.23.8.tar.gz) = 1090814
diff --git a/security/p11-kit/files/patch-common_compat.c b/security/p11-kit/files/patch-common_compat.c
new file mode 100644
index 000000000000..34a5a745d21e
--- /dev/null
+++ b/security/p11-kit/files/patch-common_compat.c
@@ -0,0 +1,10 @@
+--- common/compat.c.orig 2017-08-26 16:30:23 UTC
++++ common/compat.c
+@@ -51,6 +51,7 @@
+ #include <dirent.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include <string.h>
+
+ /*-
diff --git a/security/p11-kit/files/patch-common_debug.h b/security/p11-kit/files/patch-common_debug.h
new file mode 100644
index 000000000000..7a7877d5a213
--- /dev/null
+++ b/security/p11-kit/files/patch-common_debug.h
@@ -0,0 +1,13 @@
+--- common/debug.h.orig 2017-06-16 14:55:26 UTC
++++ common/debug.h
+@@ -144,6 +144,10 @@ void p11_debug_precond (const
+
+ #else /* !defined (WITH_DEBUG) */
+
++#undef p11_debug
++#define p11_debug(format, ...) \
++ do {} while (false)
++
+ #undef p11_debug_err
+ #define p11_debug_err(errnum, format, ...) \
+ do {} while (false)