aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Bitcard
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-16 13:09:32 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-16 13:09:32 +0000
commitaf1d88f66a0cc8a4f3616d09c86652871fc2aa1b (patch)
tree05ffa423d18aec70d4516b1968b0be56c91644d0 /security/p5-Authen-Bitcard
parentd9da78a0ff14ac0248ec3a6c091fc01aa4f7b09b (diff)
downloadports-af1d88f66a0cc8a4f3616d09c86652871fc2aa1b.tar.gz
ports-af1d88f66a0cc8a4f3616d09c86652871fc2aa1b.zip
Add p5-Authen-Bitcard 0.86, bitcard authentication verification.
PR: ports/107968 Submitted by: chinsan
Notes
Notes: svn path=/head/; revision=182518
Diffstat (limited to 'security/p5-Authen-Bitcard')
-rw-r--r--security/p5-Authen-Bitcard/Makefile32
-rw-r--r--security/p5-Authen-Bitcard/distinfo3
-rw-r--r--security/p5-Authen-Bitcard/pkg-descr8
-rw-r--r--security/p5-Authen-Bitcard/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/security/p5-Authen-Bitcard/Makefile b/security/p5-Authen-Bitcard/Makefile
new file mode 100644
index 000000000000..fe71000b3f92
--- /dev/null
+++ b/security/p5-Authen-Bitcard/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Authen-Bitcard
+# Date created: 2007/01/16
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Bitcard
+PORTVERSION= 0.86
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Bitcard authentication verification
+
+BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::Bitcard.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Bitcard/distinfo b/security/p5-Authen-Bitcard/distinfo
new file mode 100644
index 000000000000..2bc984172ae5
--- /dev/null
+++ b/security/p5-Authen-Bitcard/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Bitcard-0.86.tar.gz) = 30ac89a8bc81323d4ced63f21ad00fcc
+SHA256 (Authen-Bitcard-0.86.tar.gz) = ca3ccc317d3c70e4387ef5b3721803d0ba53b6f15988d674e9abe0e6c07029d5
+SIZE (Authen-Bitcard-0.86.tar.gz) = 11454
diff --git a/security/p5-Authen-Bitcard/pkg-descr b/security/p5-Authen-Bitcard/pkg-descr
new file mode 100644
index 000000000000..a9a930c44154
--- /dev/null
+++ b/security/p5-Authen-Bitcard/pkg-descr
@@ -0,0 +1,8 @@
+Authen::Bitcard is an implementation of verification for signatures
+generated by Bitcard authentication. For information on the Bitcard protocol
+and using Bitcard in other applications, see http://www.bitcard.org/api.
+
+The module and the protocol are heavily based on Authen::Typekey. (In fact,
+the Bitcard authentication server also supports the TypeKey API!)
+
+WWW: http://search.cpan.org/dist/Authen-Bitcard/
diff --git a/security/p5-Authen-Bitcard/pkg-plist b/security/p5-Authen-Bitcard/pkg-plist
new file mode 100644
index 000000000000..42e2d45f71e1
--- /dev/null
+++ b/security/p5-Authen-Bitcard/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/Bitcard/.packlist
+%%SITE_PERL%%/Authen/Bitcard.pm
+%%SITE_PERL%%/Sau/Client.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/Bitcard
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen
+@dirrmtry %%SITE_PERL%%/Authen
+@dirrmtry %%SITE_PERL%%/Sau