aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Radius
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-04-01 10:28:29 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-04-01 10:28:29 +0000
commit03a03b9be914fcddb5f9a2720bae67c5b79cba0b (patch)
tree1723e2a812566bc57f86dd96465d8baabb856bf1 /security/p5-Authen-Radius
parentec860200136d6e7cdbcfa7db774ebbf2c925cfcf (diff)
Notes
Diffstat (limited to 'security/p5-Authen-Radius')
-rw-r--r--security/p5-Authen-Radius/Makefile10
-rw-r--r--security/p5-Authen-Radius/distinfo2
-rw-r--r--security/p5-Authen-Radius/files/patch-aa11
-rw-r--r--security/p5-Authen-Radius/files/patch-ab9
-rw-r--r--security/p5-Authen-Radius/files/patch-ac13
5 files changed, 5 insertions, 40 deletions
diff --git a/security/p5-Authen-Radius/Makefile b/security/p5-Authen-Radius/Makefile
index c1e9b1b3a0ac..552b4b5da63e 100644
--- a/security/p5-Authen-Radius/Makefile
+++ b/security/p5-Authen-Radius/Makefile
@@ -6,24 +6,22 @@
#
PORTNAME= Authen-Radius
-PORTVERSION= 0.05
+PORTVERSION= 0.08
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Authen
-DISTNAME= RadiusPerl-0.05
+DISTNAME= RadiusPerl-${PORTVERSION}
PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl5 module to provide simple Radius client facilities
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MD5.pm:${PORTSDIR}/security/p5-MD5
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MD5.pm:${PORTSDIR}/security/p5-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Data/HexDump.pm:${PORTSDIR}/devel/p5-Data-HexDump
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Authen::Radius.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-pre-configure:
- @${CP} ${WRKSRC}/Authen/Radius.pm ${WRKSRC}
-
.include <bsd.port.mk>
diff --git a/security/p5-Authen-Radius/distinfo b/security/p5-Authen-Radius/distinfo
index c649d148e0c7..475dec47d68b 100644
--- a/security/p5-Authen-Radius/distinfo
+++ b/security/p5-Authen-Radius/distinfo
@@ -1 +1 @@
-MD5 (RadiusPerl-0.05.tar.gz) = b455bd968d3076f749f1d9ba79d176f6
+MD5 (RadiusPerl-0.08.tar.gz) = 062cc2ed8d216ff219833a1670c87d3f
diff --git a/security/p5-Authen-Radius/files/patch-aa b/security/p5-Authen-Radius/files/patch-aa
deleted file mode 100644
index c6072caca183..000000000000
--- a/security/p5-Authen-Radius/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.PL.orig Thu Sep 11 13:37:04 1997
-+++ Makefile.PL Thu Sep 11 13:37:13 1997
-@@ -4,7 +4,7 @@
- WriteMakefile(
- 'NAME' => 'Authen::Radius',
- 'DISTNAME' => 'RadiusPerl',
-- 'VERSION_FROM' => 'Authen/Radius.pm', # finds $VERSION
-+ 'VERSION_FROM' => 'Radius.pm', # finds $VERSION
- 'PREREQ_PM' => { MD5 => 1.7, IO => 1.12 },
- 'dist' => { COMPRESS => 'gzip', SUFFIX => 'gz' },
- );
diff --git a/security/p5-Authen-Radius/files/patch-ab b/security/p5-Authen-Radius/files/patch-ab
deleted file mode 100644
index ae0c4009c01a..000000000000
--- a/security/p5-Authen-Radius/files/patch-ab
+++ /dev/null
@@ -1,9 +0,0 @@
---- MANIFEST.orig Thu Sep 11 13:36:37 1997
-+++ MANIFEST Thu Sep 11 13:36:48 1997
-@@ -3,5 +3,5 @@
- README
- INSTALL
- Makefile.PL
--Authen/Radius.pm
-+Radius.pm
- test.pl
diff --git a/security/p5-Authen-Radius/files/patch-ac b/security/p5-Authen-Radius/files/patch-ac
deleted file mode 100644
index 88fd3ede7574..000000000000
--- a/security/p5-Authen-Radius/files/patch-ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- Authen/Radius.pm.orig Thu Sep 11 13:36:16 1997
-+++ Authen/Radius.pm Thu Sep 11 13:36:29 1997
-@@ -20,9 +20,8 @@
- use vars qw($VERSION @ISA @EXPORT);
-
- require Exporter;
--require AutoLoader;
-
--@ISA = qw(Exporter AutoLoader);
-+@ISA = qw(Exporter);
- @EXPORT = qw(ACCESS_REQUEST ACCESS_ACCEPT ACCESS_REJECT);
- $VERSION = '0.05';
-