aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-SASL
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /security/p5-Authen-SASL
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'security/p5-Authen-SASL')
-rw-r--r--security/p5-Authen-SASL/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/security/p5-Authen-SASL/Makefile b/security/p5-Authen-SASL/Makefile
index b96ea6b84741..78896355498f 100644
--- a/security/p5-Authen-SASL/Makefile
+++ b/security/p5-Authen-SASL/Makefile
@@ -15,16 +15,13 @@ RUN_DEPENDS= p5-Digest-HMAC>0:${PORTSDIR}/security/p5-Digest-HMAC
BUILD_DEPENDS:= ${RUN_DEPENDS}
OPTIONS_DEFINE= KERBEROS
-OPTIONS_DEFAULT= KERBEROS
+OPTIONS_DEFAULT=KERBEROS
USES= perl5
USE_PERL5= configure
CONFIGURE_ENV+= AUTOMATED_TESTING=yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MKERBEROS}
-RUN_DEPENDS+= p5-GSSAPI>0:${PORTSDIR}/security/p5-GSSAPI
-.endif
+KERBEROS_BUILD_DEPENDS= p5-GSSAPI>0:${PORTSDIR}/security/p5-GSSAPI
+KERBEROS_RUN_DEPENDS= p5-GSSAPI>0:${PORTSDIR}/security/p5-GSSAPI
.include <bsd.port.mk>