aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-SCRAM
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-26 17:39:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-26 17:39:19 +0000
commit05cb638c4d10e30f8a5e326205685ad13916caaa (patch)
tree06fb89181ca4da97cc5fa3f5d04322f111d6ada5 /security/p5-Authen-SCRAM
parent640156187b8d43b00a05f85303babf6df5f7277c (diff)
downloadports-05cb638c4d10e30f8a5e326205685ad13916caaa.tar.gz
ports-05cb638c4d10e30f8a5e326205685ad13916caaa.zip
- Add p5-Authen-SCRAM 0.005
The modules in this distribution implement the Salted Challenge Response Authentication Mechanism (SCRAM) from RFC 5802. WWW: http://search.cpan.org/dist/Authen-SCRAM/
Notes
Notes: svn path=/head/; revision=380031
Diffstat (limited to 'security/p5-Authen-SCRAM')
-rw-r--r--security/p5-Authen-SCRAM/Makefile29
-rw-r--r--security/p5-Authen-SCRAM/distinfo2
-rw-r--r--security/p5-Authen-SCRAM/pkg-descr4
-rw-r--r--security/p5-Authen-SCRAM/pkg-plist8
4 files changed, 43 insertions, 0 deletions
diff --git a/security/p5-Authen-SCRAM/Makefile b/security/p5-Authen-SCRAM/Makefile
new file mode 100644
index 000000000000..a4de187f2367
--- /dev/null
+++ b/security/p5-Authen-SCRAM/Makefile
@@ -0,0 +1,29 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Authen-SCRAM
+PORTVERSION= 0.005
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Salted Challenge Response Authentication Mechanism (RFC 5802)
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= p5-Authen-SASL-SASLprep>=0:${PORTSDIR}/security/p5-Authen-SASL-SASLprep \
+ p5-Crypt-URandom>=0:${PORTSDIR}/security/p5-Crypt-URandom \
+ p5-Moo>=1.001000:${PORTSDIR}/devel/p5-Moo \
+ p5-PBKDF2-Tiny>=0.003:${PORTSDIR}/security/p5-PBKDF2-Tiny \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-Type-Tiny>=0:${PORTSDIR}/devel/p5-Type-Tiny \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-FailWarnings>=0:${PORTSDIR}/devel/p5-Test-FailWarnings \
+ p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-SCRAM/distinfo b/security/p5-Authen-SCRAM/distinfo
new file mode 100644
index 000000000000..772d15715e45
--- /dev/null
+++ b/security/p5-Authen-SCRAM/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Authen-SCRAM-0.005.tar.gz) = 23311241549faafa9e61ee436243e24a331bbe6d6db5bfa3168f5fd43c541e91
+SIZE (Authen-SCRAM-0.005.tar.gz) = 22837
diff --git a/security/p5-Authen-SCRAM/pkg-descr b/security/p5-Authen-SCRAM/pkg-descr
new file mode 100644
index 000000000000..ae805e011f27
--- /dev/null
+++ b/security/p5-Authen-SCRAM/pkg-descr
@@ -0,0 +1,4 @@
+The modules in this distribution implement the Salted Challenge Response
+Authentication Mechanism (SCRAM) from RFC 5802.
+
+WWW: http://search.cpan.org/dist/Authen-SCRAM/
diff --git a/security/p5-Authen-SCRAM/pkg-plist b/security/p5-Authen-SCRAM/pkg-plist
new file mode 100644
index 000000000000..6ba34f27d223
--- /dev/null
+++ b/security/p5-Authen-SCRAM/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Authen/SCRAM.pm
+%%SITE_PERL%%/Authen/SCRAM/Client.pm
+%%SITE_PERL%%/Authen/SCRAM/Role/Common.pm
+%%SITE_PERL%%/Authen/SCRAM/Server.pm
+%%PERL5_MAN3%%/Authen::SCRAM.3.gz
+%%PERL5_MAN3%%/Authen::SCRAM::Client.3.gz
+%%PERL5_MAN3%%/Authen::SCRAM::Role::Common.3.gz
+%%PERL5_MAN3%%/Authen::SCRAM::Server.3.gz