aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Business-PayPal-EWP
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-07-03 09:55:19 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-07-03 09:55:19 +0000
commit20343d884d29bd2a55dd13fa52aa969b882c58f5 (patch)
tree57a0ac37fcf01448cfec0b73f027f4e400ca1d43 /security/p5-Business-PayPal-EWP
parenta3eacffbcdaeff9782ddd7fe787464a18390fb97 (diff)
downloadports-20343d884d29bd2a55dd13fa52aa969b882c58f5.tar.gz
ports-20343d884d29bd2a55dd13fa52aa969b882c58f5.zip
security/p5-Business-PayPal-EWP: Fix build with LibreSSL
PR: 199176 Approved by: Maintainer time-out
Notes
Notes: svn path=/head/; revision=417963
Diffstat (limited to 'security/p5-Business-PayPal-EWP')
-rw-r--r--security/p5-Business-PayPal-EWP/Makefile3
-rw-r--r--security/p5-Business-PayPal-EWP/files/patch-Makefile.PL11
2 files changed, 12 insertions, 2 deletions
diff --git a/security/p5-Business-PayPal-EWP/Makefile b/security/p5-Business-PayPal-EWP/Makefile
index eee906c449d1..9b0cc0873437 100644
--- a/security/p5-Business-PayPal-EWP/Makefile
+++ b/security/p5-Business-PayPal-EWP/Makefile
@@ -14,9 +14,8 @@ COMMENT= Perl extension for PayPal Encrypted Website Payments
RUN_DEPENDS= p5-Net-SSLeay>=0:security/p5-Net-SSLeay
BUILD_DEPENDS= p5-Net-SSLeay>=0:security/p5-Net-SSLeay
-USES= dos2unix perl5
+USES= dos2unix perl5 ssl
USE_PERL5= configure
-USE_OPENSSL= yes
CONFIGURE_ARGS= ${OPENSSLBASE}
.include <bsd.port.mk>
diff --git a/security/p5-Business-PayPal-EWP/files/patch-Makefile.PL b/security/p5-Business-PayPal-EWP/files/patch-Makefile.PL
new file mode 100644
index 000000000000..bf1dbc0a2120
--- /dev/null
+++ b/security/p5-Business-PayPal-EWP/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig 2015-02-28 21:17:47.891583000 +0100
++++ Makefile.PL 2015-02-28 21:21:30.013978756 +0100
+@@ -78,7 +78,7 @@
+ or die "Couldn't run `$exe_path' ($?)\n";
+
+ unless (($lib_name, $maj, $min, $letter) = $vers =~
+- /^(OpenSSL)\s+(\d+\.\d+)\.(\d+)([a-z]*)/) {
++ /^(OpenSSL|LibreSSL)\s+(\d+\.\d+)\.(\d+)([a-z]*)/) {
+ die "OpenSSL version test failed (`$vers' was returned, but\n"
+ . "couldn't be parsed). Either you have bogus OpenSSL or a new version\n"
+ . "has changed the version number format.\n";