aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Business-PayPal-EWP
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-03-20 01:08:31 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-03-20 01:08:31 +0000
commit9b438ebf03d08172b3c4620e76db34a263ce2ffe (patch)
treeea2bee2c59f73a5486096f22325a88e9d9be225a /security/p5-Business-PayPal-EWP
parent1e57ec78587c5414fd830925a60e40edde0b6350 (diff)
downloadports-9b438ebf03d08172b3c4620e76db34a263ce2ffe.tar.gz
ports-9b438ebf03d08172b3c4620e76db34a263ce2ffe.zip
- Update to 1.00
PR: 121210 Submitted by: leeym Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=209412
Diffstat (limited to 'security/p5-Business-PayPal-EWP')
-rw-r--r--security/p5-Business-PayPal-EWP/Makefile21
-rw-r--r--security/p5-Business-PayPal-EWP/distinfo6
-rw-r--r--security/p5-Business-PayPal-EWP/files/patch-EWP.pm18
-rw-r--r--security/p5-Business-PayPal-EWP/files/patch-EWP.xs4
-rw-r--r--security/p5-Business-PayPal-EWP/pkg-descr8
5 files changed, 29 insertions, 28 deletions
diff --git a/security/p5-Business-PayPal-EWP/Makefile b/security/p5-Business-PayPal-EWP/Makefile
index eebcebaac1ad..e4a2a78e57ed 100644
--- a/security/p5-Business-PayPal-EWP/Makefile
+++ b/security/p5-Business-PayPal-EWP/Makefile
@@ -7,27 +7,22 @@
#
PORTNAME= Business-PayPal-EWP
-PORTVERSION= 0.02
+PORTVERSION= 1.00
CATEGORIES= security perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Business
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= alfred@freebsd.org
-COMMENT= Perl extension to talk to paypal
+MAINTAINER= alfred@FreeBSD.org
+COMMENT= Perl extension for PayPal Encrypted Website Payments
+
+RUN_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= ${OPENSSLBASE}
-
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_UNIX2DOS= yes
MAN3= Business::PayPal::EWP.3
-post-configure:
- ${PERL} -pi -e 's/\x0d//' ${WRKSRC}/ppport.h
- ${PERL} -pi -e 's/\x0d//' ${WRKSRC}/lib/Business/PayPal/EWP.pm
-
.include <bsd.port.mk>
diff --git a/security/p5-Business-PayPal-EWP/distinfo b/security/p5-Business-PayPal-EWP/distinfo
index 6e513ae9b841..fd4fe1a82d82 100644
--- a/security/p5-Business-PayPal-EWP/distinfo
+++ b/security/p5-Business-PayPal-EWP/distinfo
@@ -1,3 +1,3 @@
-MD5 (Business-PayPal-EWP-0.02.tar.gz) = 08327a5ffaa2b76bb1b73529b4d2216a
-SHA256 (Business-PayPal-EWP-0.02.tar.gz) = c418913dfa6d6e67f78aae6bc21a732e6eb95cbb438475b899fa8d9afebd53fd
-SIZE (Business-PayPal-EWP-0.02.tar.gz) = 18615
+MD5 (Business-PayPal-EWP-1.00.tar.gz) = bb31caa10a5791f0d90c2bde9d2e9ad9
+SHA256 (Business-PayPal-EWP-1.00.tar.gz) = fd1e27c9afeec9977d424de5ba8f2fe1532a40de680fe106a6420cfe94888690
+SIZE (Business-PayPal-EWP-1.00.tar.gz) = 20032
diff --git a/security/p5-Business-PayPal-EWP/files/patch-EWP.pm b/security/p5-Business-PayPal-EWP/files/patch-EWP.pm
index 847b2e8819e1..bda109259e8d 100644
--- a/security/p5-Business-PayPal-EWP/files/patch-EWP.pm
+++ b/security/p5-Business-PayPal-EWP/files/patch-EWP.pm
@@ -1,10 +1,10 @@
---- lib/Business/PayPal/EWP.pm.old Thu May 12 10:42:19 2005
-+++ lib/Business/PayPal/EWP.pm Thu May 12 10:42:39 2005
+--- lib/Business/PayPal/EWP.pm.orig 2007-09-05 07:06:20.000000000 -0700
++++ lib/Business/PayPal/EWP.pm 2008-02-28 22:17:15.000000000 -0800
@@ -65,6 +65,7 @@
- goto END;
- }
- Net::SSLeay::BIO_free($bio);
-+ $bio = undef;
- # Reformat
- $formdata=~s/,/\n/g;
- # Encrypt and sign
+ goto END;
+ }
+ Net::SSLeay::BIO_free($bio);
++ $bio = undef;
+ # Reformat
+ $formdata=~s/,/\n/g;
+ # Encrypt and sign
diff --git a/security/p5-Business-PayPal-EWP/files/patch-EWP.xs b/security/p5-Business-PayPal-EWP/files/patch-EWP.xs
index f91783ab6ff4..768bb434781d 100644
--- a/security/p5-Business-PayPal-EWP/files/patch-EWP.xs
+++ b/security/p5-Business-PayPal-EWP/files/patch-EWP.xs
@@ -1,5 +1,5 @@
---- EWP.xs.old Thu May 12 10:40:14 2005
-+++ EWP.xs Thu May 12 10:41:55 2005
+--- EWP.xs.orig 2004-12-07 07:42:37.000000000 -0800
++++ EWP.xs 2008-02-28 21:56:45.000000000 -0800
@@ -126,8 +126,10 @@
PKCS7_free(p7);
if (bio)
diff --git a/security/p5-Business-PayPal-EWP/pkg-descr b/security/p5-Business-PayPal-EWP/pkg-descr
index e6ae9c0d5ff8..dd358ec51191 100644
--- a/security/p5-Business-PayPal-EWP/pkg-descr
+++ b/security/p5-Business-PayPal-EWP/pkg-descr
@@ -1 +1,7 @@
-This module offers an interface to Paypal's encryption scheme.
+This module wraps the sample C++/C# code which PayPal provides for working
+with Encrypted Web Payments. It contains a single function, SignAndEncrypt
+which takes the plaintext form code, private key file, public key file, and
+PayPal's public certificate, and will return the signed and encrypted code
+needed by paypal.
+
+WWW: http://search.cpan.org/dist/Business-PayPal-EWP/