aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Blowfish_PP
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 23:56:42 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 23:56:42 +0000
commit89932ed0a8b97509e3e65fee08e2964b7d237ee6 (patch)
tree12c1c08fe1515073c89277cab91964b74ca6ce74 /security/p5-Crypt-Blowfish_PP
parentc64b4ba9f091c6943469d5e686eb1dd2a9bfcd1e (diff)
downloadports-89932ed0a8b97509e3e65fee08e2964b7d237ee6.tar.gz
ports-89932ed0a8b97509e3e65fee08e2964b7d237ee6.zip
New Port: security/p5-Crypt-Blowfish_PP
Blowfish is a published algorithm written by Bruce Schneier Unlike IDEA or DES etc. there are no patent implications in using this algorithm. It uses anywhere between a 64 bit and a 448 bit key. The transform itself is fast and operates on a 64 bit block, and most of the calculation time is in initialising the context with the key data. The _PP name comes from the fact that this implementation is Pure Perl, and will not have any compatibility problems. PR: ports/43794 Submitted by: Jim Geovedi <negative@toxic.magnesium.net>
Notes
Notes: svn path=/head/; revision=74698
Diffstat (limited to 'security/p5-Crypt-Blowfish_PP')
-rw-r--r--security/p5-Crypt-Blowfish_PP/Makefile22
-rw-r--r--security/p5-Crypt-Blowfish_PP/distinfo1
-rw-r--r--security/p5-Crypt-Blowfish_PP/pkg-comment1
-rw-r--r--security/p5-Crypt-Blowfish_PP/pkg-descr10
-rw-r--r--security/p5-Crypt-Blowfish_PP/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/security/p5-Crypt-Blowfish_PP/Makefile b/security/p5-Crypt-Blowfish_PP/Makefile
new file mode 100644
index 000000000000..d00547af239a
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Crypt-Blowfish_PP
+# Date created: Sep 30, 2002
+# Whom: Jim Geovedi <jim@corebsd.or.id>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Blowfish_PP
+PORTVERSION= 1.12
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jim@corebsd.or.id
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Blowfish_PP.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Blowfish_PP/distinfo b/security/p5-Crypt-Blowfish_PP/distinfo
new file mode 100644
index 000000000000..24f55869717e
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-Blowfish_PP-1.12.tar.gz) = 6bf7dc80967eaf3047b67b26b015267d
diff --git a/security/p5-Crypt-Blowfish_PP/pkg-comment b/security/p5-Crypt-Blowfish_PP/pkg-comment
new file mode 100644
index 000000000000..a8c58aad9278
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/pkg-comment
@@ -0,0 +1 @@
+Blowfish encryption algorithm implemented purely in Perl
diff --git a/security/p5-Crypt-Blowfish_PP/pkg-descr b/security/p5-Crypt-Blowfish_PP/pkg-descr
new file mode 100644
index 000000000000..7ffaf54a5272
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/pkg-descr
@@ -0,0 +1,10 @@
+Blowfish is a published algorithm written by Bruce Schneier Unlike
+IDEA or DES etc. there are no patent implications in using this
+algorithm.
+
+It uses anywhere between a 64 bit and a 448 bit key. The transform
+itself is fast and operates on a 64 bit block, and most of the
+calculation time is in initialising the context with the key data.
+
+The _PP name comes from the fact that this implementation is Pure
+Perl, and will not have any compatibility problems.
diff --git a/security/p5-Crypt-Blowfish_PP/pkg-plist b/security/p5-Crypt-Blowfish_PP/pkg-plist
new file mode 100644
index 000000000000..95c0078786ad
--- /dev/null
+++ b/security/p5-Crypt-Blowfish_PP/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Blowfish_PP.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Blowfish_PP/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Blowfish_PP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Crypt 2>/dev/null || true