aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-CBCeasy
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-01-21 15:02:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-01-21 15:02:47 +0000
commitae4c901425fa73e9d73e19589ef0073a143a7411 (patch)
tree115ac0df2b30c1bb1ddb53fb7b9b9b39f6676d71 /security/p5-Crypt-CBCeasy
parent1b916d4d96e1fb32b79b58e7e9a56367d676c91e (diff)
downloadports-ae4c901425fa73e9d73e19589ef0073a143a7411.tar.gz
ports-ae4c901425fa73e9d73e19589ef0073a143a7411.zip
Add OPTIONS support
Notes
Notes: svn path=/head/; revision=98699
Diffstat (limited to 'security/p5-Crypt-CBCeasy')
-rw-r--r--security/p5-Crypt-CBCeasy/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/p5-Crypt-CBCeasy/Makefile b/security/p5-Crypt-CBCeasy/Makefile
index a8883acbc55c..5a1cd3dde098 100644
--- a/security/p5-Crypt-CBCeasy/Makefile
+++ b/security/p5-Crypt-CBCeasy/Makefile
@@ -19,21 +19,27 @@ BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
${SITE_PERL}/MD5.pm:${PORTSDIR}/security/p5-MD5
RUN_DEPENDS= ${BUILD_DEPENDS}
+OPTIONS= DES "Build with Crypt::DES support" on
.if !defined(WITHOUT_DES)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
.endif
+OPTIONS+= IDEA "Build with Crypt::IDEA support" on
.if !defined(WITHOUT_IDEA)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/IDEA.pm:${PORTSDIR}/security/p5-Crypt-IDEA
.endif
+OPTIONS+= BLOWFISH "Build with Crypt::Blowfish support" on
.if !defined(WITHOUT_BLOWFISH)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish
.endif
+OPTIONS+= BLOWFISH_PP "Build with Crypt::Blowfish_PP support" on
.if !defined(WITHOUT_BLOWFISH_PP)
BUILD_DEPENDS+= ${SITE_PERL}/Crypt/Blowfish_PP.pm:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
.endif
+OPTIONS+= TWOFISH2 "Build with Crypt::Twofish2 support" on
.if !defined(WITHOUT_TWOFISH2)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Twofish2.pm:${PORTSDIR}/security/p5-Crypt-Twofish2
.endif
+OPTIONS+= RIJNDAEL "Build with Crypt::Rijndael support" on
.if !defined(WITHOUT_RIJNDAEL)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael
.endif