aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Cracklib/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-27 03:07:40 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-27 03:07:40 +0000
commit672b8c0ca04104dadbb917794786fcec0db9708f (patch)
tree90dd3156360994d62febb2ef57c39a0ba0d15bf1 /security/p5-Crypt-Cracklib/Makefile
parent78480f6a7e1e7e2b9dc0eca81623fb02c84f871d (diff)
downloadports-672b8c0ca04104dadbb917794786fcec0db9708f.tar.gz
ports-672b8c0ca04104dadbb917794786fcec0db9708f.zip
Notes
Diffstat (limited to 'security/p5-Crypt-Cracklib/Makefile')
-rw-r--r--security/p5-Crypt-Cracklib/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/p5-Crypt-Cracklib/Makefile b/security/p5-Crypt-Cracklib/Makefile
new file mode 100644
index 000000000000..cce391aefc44
--- /dev/null
+++ b/security/p5-Crypt-Cracklib/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Crypt-Cracklib
+# Date created: Fri Jan 26 20:26:11 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Cracklib
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+=INC="-I${LOCALBASE}/include"
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::Cracklib.3
+
+post-patch:
+ ${PERL} -pi -e "s@INCLUDE@${LOCALBASE}/include@g;\
+ s@FBSDLIB@${LOCALBASE}/lib@g" ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>