aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-DES/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-12-09 20:16:33 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-12-09 20:16:33 +0000
commit6eef020c81cf89a77bc385ce54d8c858a25bf634 (patch)
treec67edd8842a3c41de6704c04e35562d01085fef4 /security/p5-Crypt-DES/Makefile
parent3720d61ead7da935b4fe51470ff645b93265d054 (diff)
downloadports-6eef020c81cf89a77bc385ce54d8c858a25bf634.tar.gz
ports-6eef020c81cf89a77bc385ce54d8c858a25bf634.zip
Notes
Diffstat (limited to 'security/p5-Crypt-DES/Makefile')
-rw-r--r--security/p5-Crypt-DES/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/security/p5-Crypt-DES/Makefile b/security/p5-Crypt-DES/Makefile
index 5a63e46740c5..e73fc0ab709a 100644
--- a/security/p5-Crypt-DES/Makefile
+++ b/security/p5-Crypt-DES/Makefile
@@ -6,17 +6,26 @@
#
PORTNAME= Crypt-DES
-PORTVERSION= 2.03
+PORTVERSION= 2.05
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to DES block cipher
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= Crypt::DES.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 or lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>