aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-DES
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:33:54 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:33:54 +0000
commit1e8ba55efad8fbe76d161f03ea398fabd63f3db3 (patch)
tree03b25ae8ad5628a5568a608e937b35080a2528e8 /security/p5-Crypt-DES
parentfb4418ff9f7d20e40270f6335c04836e67165990 (diff)
downloadports-1e8ba55efad8fbe76d161f03ea398fabd63f3db3.tar.gz
ports-1e8ba55efad8fbe76d161f03ea398fabd63f3db3.zip
perl5 interface to DES block cipher.
Notes
Notes: svn path=/head/; revision=4116
Diffstat (limited to 'security/p5-Crypt-DES')
-rw-r--r--security/p5-Crypt-DES/Makefile33
-rw-r--r--security/p5-Crypt-DES/distinfo1
-rw-r--r--security/p5-Crypt-DES/pkg-comment1
-rw-r--r--security/p5-Crypt-DES/pkg-descr6
-rw-r--r--security/p5-Crypt-DES/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/security/p5-Crypt-DES/Makefile b/security/p5-Crypt-DES/Makefile
new file mode 100644
index 000000000000..c9075873d2ac
--- /dev/null
+++ b/security/p5-Crypt-DES/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Crypt-DES
+# Version required: 1.0
+# Date created: October 20th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= Crypt-DES-1.0
+PKGNAME= p5-Crypt-DES-1.0
+CATEGORIES+= security
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/Crypt/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in Crypt::DES; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-DES/distinfo b/security/p5-Crypt-DES/distinfo
new file mode 100644
index 000000000000..3d018464a73b
--- /dev/null
+++ b/security/p5-Crypt-DES/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-DES-1.0.tar.gz) = 410c6e6958595f7ef3e6a37f464424e0
diff --git a/security/p5-Crypt-DES/pkg-comment b/security/p5-Crypt-DES/pkg-comment
new file mode 100644
index 000000000000..154feea77b49
--- /dev/null
+++ b/security/p5-Crypt-DES/pkg-comment
@@ -0,0 +1 @@
+perl5 interface to DES block cipher.
diff --git a/security/p5-Crypt-DES/pkg-descr b/security/p5-Crypt-DES/pkg-descr
new file mode 100644
index 000000000000..b97c1604930f
--- /dev/null
+++ b/security/p5-Crypt-DES/pkg-descr
@@ -0,0 +1,6 @@
+ This perl extension is an implementation of the DES block
+ cipher algorithm. The module implements the
+ Crypt::BlockCipher interface, which has the following
+ methods
+
+ blocksize =item keysize =item encrypt =item decrypt
diff --git a/security/p5-Crypt-DES/pkg-plist b/security/p5-Crypt-DES/pkg-plist
new file mode 100644
index 000000000000..4c696f2bbc49
--- /dev/null
+++ b/security/p5-Crypt-DES/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/man/man3/Crypt::DES.3.gz
+lib/perl5/site_perl/Crypt/DES.pm
+lib/perl5/site_perl/Crypt/DES.pod
+lib/perl5/site_perl/i386-freebsd/auto/Crypt/DES/DES.bs
+lib/perl5/site_perl/i386-freebsd/auto/Crypt/DES/DES.so
+lib/perl5/site_perl/i386-freebsd/auto/Crypt/DES/.packlist
+@dirrm lib/perl5/site_perl/i386-freebsd/auto/Crypt/DES