aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-DSA
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-09-12 01:10:17 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-09-12 01:10:17 +0000
commit5bae66dd189f204a8b62a66e0cc7210b52154711 (patch)
tree241ece24c2826846891dad82a1c27732080410d8 /security/p5-Crypt-DSA
parent409354ab19d93d995f63349d32203b368e06afe7 (diff)
downloadports-5bae66dd189f204a8b62a66e0cc7210b52154711.tar.gz
ports-5bae66dd189f204a8b62a66e0cc7210b52154711.zip
Crypt::DSA is an implementation of the DSA (Digital Signature Algorithm)
signature verification system. The implementation itself is pure Perl, although the heavy-duty mathematics underneath are provided by the Math::Pari library.
Notes
Notes: svn path=/head/; revision=47726
Diffstat (limited to 'security/p5-Crypt-DSA')
-rw-r--r--security/p5-Crypt-DSA/Makefile33
-rw-r--r--security/p5-Crypt-DSA/distinfo1
-rw-r--r--security/p5-Crypt-DSA/pkg-comment1
-rw-r--r--security/p5-Crypt-DSA/pkg-descr6
-rw-r--r--security/p5-Crypt-DSA/pkg-plist11
5 files changed, 52 insertions, 0 deletions
diff --git a/security/p5-Crypt-DSA/Makefile b/security/p5-Crypt-DSA/Makefile
new file mode 100644
index 000000000000..ab1693a0c1d0
--- /dev/null
+++ b/security/p5-Crypt-DSA/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Crypt-DSA
+# Date created: Tue Sep 11 10:31:23 PDT 2001
+# Whom: Michael Haro <mharo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-DSA
+PORTVERSION= 0.12
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mharo@FreeBSD.org
+
+PERLBASE= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+BUILD_DEPENDS= ${PERLBASE}/Crypt/Random.pm:${PORTSDIR}/security/p5-Crypt-Random \
+ ${PERLBASE}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${PERLBASE}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
+ ${PERLBASE}/Convert/PEM.pm:${PORTSDIR}/converters/p5-Convert-PEM
+
+RESTRICTED= "Crypto; export-controlled"
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::DSA::Key::SSH2.3 Crypt::DSA.3 Crypt::DSA::Key.3 \
+ Crypt::DSA::Key::PEM.3 Crypt::DSA::Signature.3 \
+ Crypt::DSA::KeyChain.3 Crypt::DSA::Util.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-DSA/distinfo b/security/p5-Crypt-DSA/distinfo
new file mode 100644
index 000000000000..2e0f9555fcdc
--- /dev/null
+++ b/security/p5-Crypt-DSA/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-DSA-0.12.tar.gz) = 7324f8d65f041b153b6b4beeaeb9a953
diff --git a/security/p5-Crypt-DSA/pkg-comment b/security/p5-Crypt-DSA/pkg-comment
new file mode 100644
index 000000000000..ab364d2c2337
--- /dev/null
+++ b/security/p5-Crypt-DSA/pkg-comment
@@ -0,0 +1 @@
+DSA signature and key generation
diff --git a/security/p5-Crypt-DSA/pkg-descr b/security/p5-Crypt-DSA/pkg-descr
new file mode 100644
index 000000000000..d1a168034f68
--- /dev/null
+++ b/security/p5-Crypt-DSA/pkg-descr
@@ -0,0 +1,6 @@
+Crypt::DSA is an implementation of the DSA (Digital Signature Algorithm)
+signature verification system. The implementation itself is pure Perl,
+although the heavy-duty mathematics underneath are provided by the
+Math::Pari library.
+
+This package provides DSA signing, signature verification, and key generation.
diff --git a/security/p5-Crypt-DSA/pkg-plist b/security/p5-Crypt-DSA/pkg-plist
new file mode 100644
index 000000000000..c1d778730033
--- /dev/null
+++ b/security/p5-Crypt-DSA/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA/Key/SSH2.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA/Key/PEM.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA/Key.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA/Signature.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA/KeyChain.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA/Util.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/DSA/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA/Key
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/DSA
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/DSA