aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-GCrypt
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-06 04:58:39 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-06 04:58:39 +0000
commit281c4c0d24cfc84525f2f9e7f18d657f95e6ca3f (patch)
tree5cd3b7052a4926c5513a7b483bece89388b27049 /security/p5-Crypt-GCrypt
parentc69273cf1a0aac36b3aadbac101d8b64837381eb (diff)
downloadports-281c4c0d24cfc84525f2f9e7f18d657f95e6ca3f.tar.gz
ports-281c4c0d24cfc84525f2f9e7f18d657f95e6ca3f.zip
Add p5-Crypt-GCrypt 1.15, perl interface to the GNU Cryptographic
library. PR: ports/103767 Submitted by: TAKAHASHI Kaoru <kaoru at kaisei.org>
Notes
Notes: svn path=/head/; revision=174630
Diffstat (limited to 'security/p5-Crypt-GCrypt')
-rw-r--r--security/p5-Crypt-GCrypt/Makefile37
-rw-r--r--security/p5-Crypt-GCrypt/distinfo3
-rw-r--r--security/p5-Crypt-GCrypt/pkg-descr3
-rw-r--r--security/p5-Crypt-GCrypt/pkg-plist8
4 files changed, 51 insertions, 0 deletions
diff --git a/security/p5-Crypt-GCrypt/Makefile b/security/p5-Crypt-GCrypt/Makefile
new file mode 100644
index 000000000000..9ff8a42c4a29
--- /dev/null
+++ b/security/p5-Crypt-GCrypt/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Crypt-GCrypt
+# Date created: 2006-09-28
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-GCrypt
+PORTVERSION= 1.15
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kaoru@kaisei.org
+COMMENT= Perl interface to the GNU Cryptographic library
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= GCRYPTLIBPATH=${LOCALBASE}/lib \
+ GCRYPTINCPATH=${LOCALBASE}/include
+USE_GCC= 3.2+
+
+MAN3= Crypt::GCrypt.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -pi -e 's/^our (\W\w+);/use vars q($$1);/o;' \
+ -e 's/^our\s+(\W\w+)(?!;)/use vars q($$1); $$1/o;' \
+ -e 'undef $$_ if /^\s*(no|use) warnings/o;' \
+ ${WRKSRC}/GCrypt.pm ${WRKSRC}/Makefile.PL
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-GCrypt/distinfo b/security/p5-Crypt-GCrypt/distinfo
new file mode 100644
index 000000000000..7d6b2edc0731
--- /dev/null
+++ b/security/p5-Crypt-GCrypt/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-GCrypt-1.15.tar.gz) = 9da32ac299ff3a2b3126158b55e02131
+SHA256 (Crypt-GCrypt-1.15.tar.gz) = 7f05cbc7e10c66c3075ea8cb79f4c038cf8f18fdcb192ac66305c07fa41dbcc6
+SIZE (Crypt-GCrypt-1.15.tar.gz) = 15667
diff --git a/security/p5-Crypt-GCrypt/pkg-descr b/security/p5-Crypt-GCrypt/pkg-descr
new file mode 100644
index 000000000000..6ae2c1fe47a8
--- /dev/null
+++ b/security/p5-Crypt-GCrypt/pkg-descr
@@ -0,0 +1,3 @@
+Crypt::GCrypt provides an object interface to the C libgcrypt library.
+It currently supports symmetric encryption/decryption, while asymmetric
+cryptography is being worked on.
diff --git a/security/p5-Crypt-GCrypt/pkg-plist b/security/p5-Crypt-GCrypt/pkg-plist
new file mode 100644
index 000000000000..475065cdd021
--- /dev/null
+++ b/security/p5-Crypt-GCrypt/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/GCrypt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GCrypt/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GCrypt/GCrypt.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GCrypt/GCrypt.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GCrypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt