aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-GCrypt
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /security/p5-Crypt-GCrypt
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'security/p5-Crypt-GCrypt')
-rw-r--r--security/p5-Crypt-GCrypt/Makefile4
-rw-r--r--security/p5-Crypt-GCrypt/pkg-plist11
2 files changed, 5 insertions, 10 deletions
diff --git a/security/p5-Crypt-GCrypt/Makefile b/security/p5-Crypt-GCrypt/Makefile
index cbc5933bdcc4..65b242c374e6 100644
--- a/security/p5-Crypt-GCrypt/Makefile
+++ b/security/p5-Crypt-GCrypt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Crypt-GCrypt
PORTVERSION= 1.26
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -22,6 +22,6 @@ USE_PERL5= configure
USES= perl5
post-stage:
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Crypt/GCrypt/GCrypt.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Crypt/GCrypt/GCrypt.so
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-GCrypt/pkg-plist b/security/p5-Crypt-GCrypt/pkg-plist
index 8f3b74d94014..7ce00bdfd3a0 100644
--- a/security/p5-Crypt-GCrypt/pkg-plist
+++ b/security/p5-Crypt-GCrypt/pkg-plist
@@ -1,10 +1,5 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/GCrypt.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/GCrypt/MPI.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GCrypt/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GCrypt/GCrypt.so
+%%SITE_ARCH%%/Crypt/GCrypt.pm
+%%SITE_ARCH%%/Crypt/GCrypt/MPI.pm
+%%SITE_ARCH%%/auto/Crypt/GCrypt/GCrypt.so
%%PERL5_MAN3%%/Crypt::GCrypt.3.gz
%%PERL5_MAN3%%/Crypt::GCrypt::MPI.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/GCrypt
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GCrypt
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt