aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Loki97
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-03-31 20:33:58 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-03-31 20:33:58 +0000
commitc5fb2bb5569face0b9e8dd08993295fbc44c660a (patch)
treee967594121176f847548a780938793adf0e028e2 /security/p5-Crypt-Loki97
parent62a32f108169b463244dbde90bc50a10b18e45f4 (diff)
downloadports-c5fb2bb5569face0b9e8dd08993295fbc44c660a.tar.gz
ports-c5fb2bb5569face0b9e8dd08993295fbc44c660a.zip
- Remove support for old Perl from my ports
Notes
Notes: svn path=/head/; revision=188903
Diffstat (limited to 'security/p5-Crypt-Loki97')
-rw-r--r--security/p5-Crypt-Loki97/Makefile15
-rw-r--r--security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs18
2 files changed, 1 insertions, 32 deletions
diff --git a/security/p5-Crypt-Loki97/Makefile b/security/p5-Crypt-Loki97/Makefile
index 5aa3d02d0326..bda145288a6e 100644
--- a/security/p5-Crypt-Loki97/Makefile
+++ b/security/p5-Crypt-Loki97/Makefile
@@ -17,17 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Loki97.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
-RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
-EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Loki97.xs
-
-post-patch:
- ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Loki97.pm
- ${PERL} -pi -e 's/void/int argc, char**argv, char**env/ if m{int main}' ${WRKSRC}/_loki97.c
- ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Loki97.pm ${WRKSRC}/t/*.t
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs b/security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs
deleted file mode 100644
index f2e7f9ebb40c..000000000000
--- a/security/p5-Crypt-Loki97/files/extrapatch-Loki97.xs
+++ /dev/null
@@ -1,18 +0,0 @@
---- Loki97.xs.orig Sat Dec 31 03:04:38 2005
-+++ Loki97.xs Sat Dec 31 03:05:06 2005
-@@ -4,6 +4,15 @@
- #include "ppport.h"
- #include "_loki97.c"
-
-+/* try to be compatible with older perls */
-+/* SvPV_nolen() macro first defined in 5.005_55 */
-+/* this is slow, not threadsafe, but works */
-+#include "patchlevel.h"
-+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
-+static STRLEN nolen_na;
-+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
-+#endif
-+
- typedef struct loki97 {
- keyInstance enc_key, dec_key;
- cipherInstance cipher;