aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-OTP
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-01-26 03:01:41 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-01-26 03:01:41 +0000
commit7b6c9b4ed1cd6795ab2e8e925698d831f2b7f7a1 (patch)
treeff1aad414b6d056ec993b5b740cfb513e770b77a /security/p5-Crypt-OTP
parent2f32ba326d75e08f77d33cc472f9f12b61f63099 (diff)
downloadports-7b6c9b4ed1cd6795ab2e8e925698d831f2b7f7a1.tar.gz
ports-7b6c9b4ed1cd6795ab2e8e925698d831f2b7f7a1.zip
Add p5-Crypt-OTP 1.03, perl implementation of the One Time Pad
(hence, OTP) encryption method. PR: 33362 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Notes
Notes: svn path=/head/; revision=53742
Diffstat (limited to 'security/p5-Crypt-OTP')
-rw-r--r--security/p5-Crypt-OTP/Makefile22
-rw-r--r--security/p5-Crypt-OTP/distinfo1
-rw-r--r--security/p5-Crypt-OTP/pkg-comment1
-rw-r--r--security/p5-Crypt-OTP/pkg-descr9
-rw-r--r--security/p5-Crypt-OTP/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/security/p5-Crypt-OTP/Makefile b/security/p5-Crypt-OTP/Makefile
new file mode 100644
index 000000000000..b70a315e2e0e
--- /dev/null
+++ b/security/p5-Crypt-OTP/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Crypt::OTP
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OTP
+PORTVERSION= 1.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OTP.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OTP/distinfo b/security/p5-Crypt-OTP/distinfo
new file mode 100644
index 000000000000..9493d22d4187
--- /dev/null
+++ b/security/p5-Crypt-OTP/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-OTP-1.03.tar.gz) = 53fbe88beeb9530ef7cca7b9b3bafadc
diff --git a/security/p5-Crypt-OTP/pkg-comment b/security/p5-Crypt-OTP/pkg-comment
new file mode 100644
index 000000000000..a5e548131c24
--- /dev/null
+++ b/security/p5-Crypt-OTP/pkg-comment
@@ -0,0 +1 @@
+Perl implementation of the One Time Pad (hence, OTP) encryption method
diff --git a/security/p5-Crypt-OTP/pkg-descr b/security/p5-Crypt-OTP/pkg-descr
new file mode 100644
index 000000000000..895c9796c7bf
--- /dev/null
+++ b/security/p5-Crypt-OTP/pkg-descr
@@ -0,0 +1,9 @@
+The One Time Pad encryption method is very simple, and impossible
+to crack without the actual pad file against which the to-be-encrypted
+message is XOR'ed. Encryption and decryption are performed using
+excactly the same method, and the message will decrypt correctly
+only if the same pad is used in decryption as was use in encryption.
+
+WWW: http://search.cpan.org/search?dist=Crypt-OTP
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/security/p5-Crypt-OTP/pkg-plist b/security/p5-Crypt-OTP/pkg-plist
new file mode 100644
index 000000000000..b3f1977d93b0
--- /dev/null
+++ b/security/p5-Crypt-OTP/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/OTP.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Crypt/OTP/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OTP/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/OTP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Crypt/OTP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Crypt 2>/dev/null || true