aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-PassGen
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-07 15:57:10 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-07 15:57:10 +0000
commit6ecd568c10c195f3963bb0579ab8957593c24406 (patch)
tree82204b1dcc46b30e8c281ce0cbee8cb67429fce9 /security/p5-Crypt-PassGen
parentdd0b571734ae390282276873b867ef9768dde3c2 (diff)
downloadports-6ecd568c10c195f3963bb0579ab8957593c24406.tar.gz
ports-6ecd568c10c195f3963bb0579ab8957593c24406.zip
Add p5-Crypt-PassGen, a perl module to generate random passwords that
look like real words.
Notes
Notes: svn path=/head/; revision=48524
Diffstat (limited to 'security/p5-Crypt-PassGen')
-rw-r--r--security/p5-Crypt-PassGen/Makefile25
-rw-r--r--security/p5-Crypt-PassGen/distinfo1
-rw-r--r--security/p5-Crypt-PassGen/pkg-comment1
-rw-r--r--security/p5-Crypt-PassGen/pkg-descr17
-rw-r--r--security/p5-Crypt-PassGen/pkg-plist6
5 files changed, 50 insertions, 0 deletions
diff --git a/security/p5-Crypt-PassGen/Makefile b/security/p5-Crypt-PassGen/Makefile
new file mode 100644
index 000000000000..dc247abc0e2a
--- /dev/null
+++ b/security/p5-Crypt-PassGen/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: security/p5-Crypt-PassGen
+# Date created: 07 October 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-PassGen
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::PassGen.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-PassGen/distinfo b/security/p5-Crypt-PassGen/distinfo
new file mode 100644
index 000000000000..1f83d3f298a5
--- /dev/null
+++ b/security/p5-Crypt-PassGen/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-PassGen-0.02.tar.gz) = 158c58f7ffda889077c40cbeb44561ff
diff --git a/security/p5-Crypt-PassGen/pkg-comment b/security/p5-Crypt-PassGen/pkg-comment
new file mode 100644
index 000000000000..d593121ad1e9
--- /dev/null
+++ b/security/p5-Crypt-PassGen/pkg-comment
@@ -0,0 +1 @@
+Crypt::PassGen - Generate a random password that looks like a real word
diff --git a/security/p5-Crypt-PassGen/pkg-descr b/security/p5-Crypt-PassGen/pkg-descr
new file mode 100644
index 000000000000..6336b7a98a32
--- /dev/null
+++ b/security/p5-Crypt-PassGen/pkg-descr
@@ -0,0 +1,17 @@
+This module provides a single command for generating random password
+that is close enough to a real word that it is easy to remember. It
+does this by using the frequency of letter combinations in a language
+(the frequency table is generated during installation although multiple
+tables can be generated and used for different languages).
+
+This module should not be used for high security applications (such as
+user accounts) since it returns passwords that are not mixed case, have
+no punctuation and no letters. This word can be used as a basis for a
+more secure password.
+
+The language of the password depends on the language used to construct
+the frequency table.
+
+WWW: http://search.cpan.org/search?dist=Crypt-PassGen
+
+-Anton
diff --git a/security/p5-Crypt-PassGen/pkg-plist b/security/p5-Crypt-PassGen/pkg-plist
new file mode 100644
index 000000000000..1219a265e71a
--- /dev/null
+++ b/security/p5-Crypt-PassGen/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/PassGen/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/PassGenWordFreq.dat
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/PassGen.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/PassGen
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Crypt 2>/dev/null || true