aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-SKey
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-21 15:40:50 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-21 15:40:50 +0000
commit89a50ab6386a57ca49265fc79f8f3251c0327686 (patch)
tree5463e92f28d14c2168c5eabee7343106cefe3ea2 /security/p5-Crypt-SKey
parenta0ef1b0ad62b84dc70476e76dca9579ed72ef1b3 (diff)
downloadports-89a50ab6386a57ca49265fc79f8f3251c0327686.tar.gz
ports-89a50ab6386a57ca49265fc79f8f3251c0327686.zip
This module contains a simple S/Key calculator (as described in RFC
1760) implemented in Perl. It exports the function `key' by default, and may optionally export the function `compute'. `compute_md4', `compute_md5', `key_md4', and `key_md5' are provided as convenience functions for selecting either MD4 or MD5 hashes. The default is MD4; this may be changed with with the `$Crypt::SKey::HASH' variable, assigning it the value of `MD4' or `MD5'. You can access any of these functions by exporting them in the same manner as `compute' in the above example. Most S/Key systems use MD4 hashing, but a few (notably OPIE) use MD5. WWW: http://search.cpan.org/dist/Crypt-SKey PR: ports/90695 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151763
Diffstat (limited to 'security/p5-Crypt-SKey')
-rw-r--r--security/p5-Crypt-SKey/Makefile24
-rw-r--r--security/p5-Crypt-SKey/distinfo3
-rw-r--r--security/p5-Crypt-SKey/pkg-descr12
-rw-r--r--security/p5-Crypt-SKey/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/security/p5-Crypt-SKey/Makefile b/security/p5-Crypt-SKey/Makefile
new file mode 100644
index 000000000000..6200b4b26a90
--- /dev/null
+++ b/security/p5-Crypt-SKey/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-SKey
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-SKey
+PORTVERSION= 0.07
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl S/Key calculator
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::SKey.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-SKey/distinfo b/security/p5-Crypt-SKey/distinfo
new file mode 100644
index 000000000000..eb4d84eba224
--- /dev/null
+++ b/security/p5-Crypt-SKey/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-SKey-0.07.tar.gz) = 43375e8c7acb3d1f6ad060e989f7b5b0
+SHA256 (Crypt-SKey-0.07.tar.gz) = c57f6ab4852ef3f4f8051ea2a00841278260e140be4cf3b5f71fd699c973ec04
+SIZE (Crypt-SKey-0.07.tar.gz) = 12536
diff --git a/security/p5-Crypt-SKey/pkg-descr b/security/p5-Crypt-SKey/pkg-descr
new file mode 100644
index 000000000000..e3ba17763a1b
--- /dev/null
+++ b/security/p5-Crypt-SKey/pkg-descr
@@ -0,0 +1,12 @@
+This module contains a simple S/Key calculator (as described in RFC
+1760) implemented in Perl. It exports the function `key' by default, and
+may optionally export the function `compute'.
+`compute_md4', `compute_md5', `key_md4', and `key_md5' are provided as
+convenience functions for selecting either MD4 or MD5 hashes. The
+default is MD4; this may be changed with with the `$Crypt::SKey::HASH'
+variable, assigning it the value of `MD4' or `MD5'. You can access any
+of these functions by exporting them in the same manner as `compute' in
+the above example.
+Most S/Key systems use MD4 hashing, but a few (notably OPIE) use MD5.
+
+WWW: http://search.cpan.org/dist/Crypt-SKey
diff --git a/security/p5-Crypt-SKey/pkg-plist b/security/p5-Crypt-SKey/pkg-plist
new file mode 100644
index 000000000000..41cc5d7a985b
--- /dev/null
+++ b/security/p5-Crypt-SKey/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/SKey.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/SKey/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/SKey/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true