aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-SSLeay
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
commit927c9c2190303cbf488da40b21aa8f687198bb23 (patch)
treeb50875b389c063d1bcadc768e710973b1992efd2 /security/p5-Crypt-SSLeay
parent2a6d3bd8e2df3f99bd5bc37be426951c272419b9 (diff)
downloadports-927c9c2190303cbf488da40b21aa8f687198bb23.tar.gz
ports-927c9c2190303cbf488da40b21aa8f687198bb23.zip
Conditionalize dependencies for moudules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. 17 + 29 + 234 = 280 PRs. It's about time he starts doing the work himself! PR: ports/50588 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=78882
Diffstat (limited to 'security/p5-Crypt-SSLeay')
-rw-r--r--security/p5-Crypt-SSLeay/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/security/p5-Crypt-SSLeay/Makefile b/security/p5-Crypt-SSLeay/Makefile
index 47f95779ae65..5c216aced13d 100644
--- a/security/p5-Crypt-SSLeay/Makefile
+++ b/security/p5-Crypt-SSLeay/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Perl5 interface to allow p5-libwww LWP to make https connections
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI/URL.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI/URL.pm:${PORTSDIR}/net/p5-URI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -26,4 +25,12 @@ USE_OPENSSL= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Crypt::SSLeay.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
+