aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Simple
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-05 16:14:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-05 16:14:15 +0000
commit62398fb0e689e719b7af4eb1234d0c47fdfe486a (patch)
tree867765e82affcf1507a9f50eafb2593dfb6df35e /security/p5-Crypt-Simple
parent704a7de7ca7a273d453d7bde29c3d8d9ff69933f (diff)
downloadports-62398fb0e689e719b7af4eb1234d0c47fdfe486a.tar.gz
ports-62398fb0e689e719b7af4eb1234d0c47fdfe486a.zip
Notes
Diffstat (limited to 'security/p5-Crypt-Simple')
-rw-r--r--security/p5-Crypt-Simple/Makefile28
-rw-r--r--security/p5-Crypt-Simple/distinfo3
-rw-r--r--security/p5-Crypt-Simple/pkg-descr3
-rw-r--r--security/p5-Crypt-Simple/pkg-plist6
4 files changed, 40 insertions, 0 deletions
diff --git a/security/p5-Crypt-Simple/Makefile b/security/p5-Crypt-Simple/Makefile
new file mode 100644
index 000000000000..fc190225b379
--- /dev/null
+++ b/security/p5-Crypt-Simple/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Crypt-Simple
+# Date created: 01 Jun 2010
+# Whom: Alexander Kriventsov <avk@vl.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Simple
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= avk@vl.ru
+COMMENT= Perl encrypt stuff simply
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
+ ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Simple.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Simple/distinfo b/security/p5-Crypt-Simple/distinfo
new file mode 100644
index 000000000000..e61aa8b4a72b
--- /dev/null
+++ b/security/p5-Crypt-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Simple-0.06.tar.gz) = cdea18a98593364855f27afcb8519ec0
+SHA256 (Crypt-Simple-0.06.tar.gz) = 3db6e7754eaa425ab2d958d40b62d2026b0b186cd576ee352b4c172fb52d8e17
+SIZE (Crypt-Simple-0.06.tar.gz) = 4336
diff --git a/security/p5-Crypt-Simple/pkg-descr b/security/p5-Crypt-Simple/pkg-descr
new file mode 100644
index 000000000000..ee18739574d5
--- /dev/null
+++ b/security/p5-Crypt-Simple/pkg-descr
@@ -0,0 +1,3 @@
+Perl encrypt stuff simply
+
+WWW: http://search.cpan.org/dist/Crypt-Simple/
diff --git a/security/p5-Crypt-Simple/pkg-plist b/security/p5-Crypt-Simple/pkg-plist
new file mode 100644
index 000000000000..5fea0abaecd7
--- /dev/null
+++ b/security/p5-Crypt-Simple/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Simple/.packlist
+%%SITE_PERL%%/Crypt/Simple.pm
+@dirrmtry %%SITE_PERL%%/Crypt/Simple
+@dirrmtry %%SITE_PERL%%/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt