aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Tea_JS
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-09-01 19:15:47 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-09-01 19:15:47 +0000
commit8daab8b985c60174e57cccfeeff00b30cd73dccf (patch)
treefa37e34b500946a2723731940a53833cd29193b6 /security/p5-Crypt-Tea_JS
parent55c143d426ddfe21f8b350e9902c776d82bcc60f (diff)
downloadports-8daab8b985c60174e57cccfeeff00b30cd73dccf.tar.gz
ports-8daab8b985c60174e57cccfeeff00b30cd73dccf.zip
Add security/p5-Crypt-Tea_JS.
security/p5-Crypt-T_e_a development stopped at 2.11 and there will be no further releases for that port. Development has continued by the same author, under a new name, Crypt::Tea_JS. I've added conflicts between the two, but p5-Crypt-T_e_a should probably be considered deprecated. This module implements TEA, the Tiny Encryption Algorithm, and some Modes of Use, in Perl and JavaScript. The $key is a sufficiently longish string; at least 17 random 8-bit bytes for single encryption. Crypt::Tea_JS can be used for secret-key encryption in general, or, in particular, to communicate securely between browser and web-host. In this case, the simplest arrangement is for the user to enter the key into a JavaScript variable, and for the host to retrieve that user's key from a database. Or, for extra security, the first message (or even each message) between browser and host could contain a random challenge-string, which each end would then turn into a signature, and use that signature as the encryption-key for the session (or the reply). WWW: http://search.cpan.org/dist/Crypt-Tea_JS/
Notes
Notes: svn path=/head/; revision=366933
Diffstat (limited to 'security/p5-Crypt-Tea_JS')
-rw-r--r--security/p5-Crypt-Tea_JS/Makefile28
-rw-r--r--security/p5-Crypt-Tea_JS/distinfo2
-rw-r--r--security/p5-Crypt-Tea_JS/pkg-descr16
-rw-r--r--security/p5-Crypt-Tea_JS/pkg-plist9
4 files changed, 55 insertions, 0 deletions
diff --git a/security/p5-Crypt-Tea_JS/Makefile b/security/p5-Crypt-Tea_JS/Makefile
new file mode 100644
index 000000000000..ef37ee6c1d43
--- /dev/null
+++ b/security/p5-Crypt-Tea_JS/Makefile
@@ -0,0 +1,28 @@
+# Created by: adamw
+# $FreeBSD$
+
+PORTNAME= Crypt-Tea_JS
+PORTVERSION= 2.23
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Tiny Encryption Algorithm in Perl and Javascript
+
+CONFLICTS= p5-Crypt-T_e_a-[0-9]*
+
+USES= perl5
+USE_PERL5= configure
+
+OPTIONS_DEFINE= EXAMPLES
+PORTEXAMPLES= tea_demo.cgi
+PORTDATA= Tea_JS.js
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Tea_JS.js ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Tea_JS/distinfo b/security/p5-Crypt-Tea_JS/distinfo
new file mode 100644
index 000000000000..4cff97a99fa0
--- /dev/null
+++ b/security/p5-Crypt-Tea_JS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-Tea_JS-2.23.tar.gz) = b9c5af99ddca84611cd5c6cbd5d5a5989009d5a42818f4e64e735da25676e918
+SIZE (Crypt-Tea_JS-2.23.tar.gz) = 21510
diff --git a/security/p5-Crypt-Tea_JS/pkg-descr b/security/p5-Crypt-Tea_JS/pkg-descr
new file mode 100644
index 000000000000..e6b6edb64dcd
--- /dev/null
+++ b/security/p5-Crypt-Tea_JS/pkg-descr
@@ -0,0 +1,16 @@
+This module implements TEA, the Tiny Encryption Algorithm, and some Modes of
+Use, in Perl and JavaScript.
+
+The $key is a sufficiently longish string; at least 17 random 8-bit bytes for
+single encryption.
+
+Crypt::Tea_JS can be used for secret-key encryption in general, or, in
+particular, to communicate securely between browser and web-host. In this case,
+the simplest arrangement is for the user to enter the key into a JavaScript
+variable, and for the host to retrieve that user's key from a database. Or, for
+extra security, the first message (or even each message) between browser and
+host could contain a random challenge-string, which each end would then turn
+into a signature, and use that signature as the encryption-key for the session
+(or the reply).
+
+WWW: http://search.cpan.org/dist/Crypt-Tea_JS/
diff --git a/security/p5-Crypt-Tea_JS/pkg-plist b/security/p5-Crypt-Tea_JS/pkg-plist
new file mode 100644
index 000000000000..13ae4e9d6888
--- /dev/null
+++ b/security/p5-Crypt-Tea_JS/pkg-plist
@@ -0,0 +1,9 @@
+bin/tea
+man/man1/tea.1.gz
+%%PERL5_MAN3%%/Crypt::Tea_JS.3.gz
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Tea_JS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Tea_JS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Tea_JS/Tea_JS.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Tea_JS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt