aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Twofish_PP
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-01-20 06:05:28 +0000
committerWen Heping <wen@FreeBSD.org>2011-01-20 06:05:28 +0000
commit846424b94e1be50d7dbc15cebb587a952f2e60a3 (patch)
tree1eb84c40377e8fd3b9af7a7761e449bad1f2bb18 /security/p5-Crypt-Twofish_PP
parent5dc9559734692b342db6025eebe8122c309c4239 (diff)
downloadports-846424b94e1be50d7dbc15cebb587a952f2e60a3.tar.gz
ports-846424b94e1be50d7dbc15cebb587a952f2e60a3.zip
Twofish is a 128-bit symmetric block cipher with a variable key
length (128, 192, or 256 bits) key, developed by Counterpane Labs. It is unpatented and free for all uses, as described at http://www.counterpane.com/twofish.html. It has been one of the five finalists for AES. This module is written in pure Perl, it should run everywhere where Perl runs. WWW: http://search.cpan.org/dist/Crypt-Twofish_PP/ PR: ports/154142 Submitted by: Konstantin Menshikov <kostjnspb@yandex.ru> Feature safe: yes
Notes
Notes: svn path=/head/; revision=268013
Diffstat (limited to 'security/p5-Crypt-Twofish_PP')
-rw-r--r--security/p5-Crypt-Twofish_PP/Makefile25
-rw-r--r--security/p5-Crypt-Twofish_PP/distinfo2
-rw-r--r--security/p5-Crypt-Twofish_PP/pkg-descr10
-rw-r--r--security/p5-Crypt-Twofish_PP/pkg-plist12
4 files changed, 49 insertions, 0 deletions
diff --git a/security/p5-Crypt-Twofish_PP/Makefile b/security/p5-Crypt-Twofish_PP/Makefile
new file mode 100644
index 000000000000..5e85bb1a3cd5
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Crypt-Twofish_PP
+# Date created: 19 January 2010
+# Whom: Konstantin Menshikov <kostjnspb@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Twofish_PP
+PORTVERSION= 0.17
+CATEGORIES= security perl5
+MASTER_SITES= CPAN \
+ http://kostjn.spb.ru/freebsd/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kostjnspb@yandex.ru
+COMMENT= The Twofish Algorithm in Pure Perl
+
+PERL_CONFIGURE= YES
+
+MAN3= Crypt::Twofish_PP.3 \
+ Crypt::Twofish_PP::Key16.3 \
+ Crypt::Twofish_PP::Key24.3 \
+ Crypt::Twofish_PP::Key32.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Twofish_PP/distinfo b/security/p5-Crypt-Twofish_PP/distinfo
new file mode 100644
index 000000000000..c2aa8a7bf740
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-Twofish_PP-0.17.tar.gz) = e7e2736cd7f379227f818ea2e8e586594773eb4c2fd8ec5c8c4d9662003b8bab
+SIZE (Crypt-Twofish_PP-0.17.tar.gz) = 46306
diff --git a/security/p5-Crypt-Twofish_PP/pkg-descr b/security/p5-Crypt-Twofish_PP/pkg-descr
new file mode 100644
index 000000000000..de66ed1ad7e9
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/pkg-descr
@@ -0,0 +1,10 @@
+Twofish is a 128-bit symmetric block cipher with a variable key
+length (128, 192, or 256 bits) key, developed by Counterpane Labs.
+It is unpatented and free for all uses, as described at
+http://www.counterpane.com/twofish.html. It has been one of the
+five finalists for AES.
+
+This module is written in pure Perl, it should run everywhere
+where Perl runs.
+
+WWW: http://search.cpan.org/dist/Crypt-Twofish_PP/
diff --git a/security/p5-Crypt-Twofish_PP/pkg-plist b/security/p5-Crypt-Twofish_PP/pkg-plist
new file mode 100644
index 000000000000..a7e49518f81a
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt-Twofish_PP/.packlist
+%%SITE_PERL%%/Crypt/Twofish_PP.pm
+%%SITE_PERL%%/Crypt/Twofish_PP/Key16.pm
+%%SITE_PERL%%/Crypt/Twofish_PP/Key24.pm
+%%SITE_PERL%%/Crypt/Twofish_PP/Key32.pm
+%%SITE_PERL%%/LocaleData/de/LC_MESSAGES/Crypt-Twofish_PP.mo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt-Twofish_PP
+@dirrmtry %%SITE_PERL%%/Crypt/Twofish_PP
+@dirrmtry %%SITE_PERL%%/Crypt
+@dirrmtry %%SITE_PERL%%/LocaleData/de/LC_MESSAGES
+@dirrmtry %%SITE_PERL%%/LocaleData/de
+@dirrmtry %%SITE_PERL%%/LocaleData