aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Dancer-Plugin-Passphrase
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-01-24 13:51:08 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-01-24 13:51:08 +0000
commit87a8c001f72b1a982d363b1b1230cc548ac75ba2 (patch)
treeddaf51aaab1622f9c2ef8971bd7200b4738d09ac /security/p5-Dancer-Plugin-Passphrase
parent167ba90ec7c1f76e7c0b3f8f20c6d54267bf99c8 (diff)
downloadports-87a8c001f72b1a982d363b1b1230cc548ac75ba2.tar.gz
ports-87a8c001f72b1a982d363b1b1230cc548ac75ba2.zip
Dancer::Plugin::Passphrase manages the hashing of passwords for Dancer apps,
allowing developers to follow best cryptography practice without having to become a cryptography expert. It uses the bcrypt algorithm as the default, wrapping Crypt::Eksblowfish::Bcrypt, and also supports any hashing function provided by Digest. WWW: http://search.cpan.org/dist/Dancer-Plugin-Passphrase/ PR: ports/164427 Submitted by: Grzegorz Blach <magik@roorback.net>
Notes
Notes: svn path=/head/; revision=289736
Diffstat (limited to 'security/p5-Dancer-Plugin-Passphrase')
-rw-r--r--security/p5-Dancer-Plugin-Passphrase/Makefile32
-rw-r--r--security/p5-Dancer-Plugin-Passphrase/distinfo2
-rw-r--r--security/p5-Dancer-Plugin-Passphrase/pkg-descr7
-rw-r--r--security/p5-Dancer-Plugin-Passphrase/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/security/p5-Dancer-Plugin-Passphrase/Makefile b/security/p5-Dancer-Plugin-Passphrase/Makefile
new file mode 100644
index 000000000000..5b185b123c10
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Passphrase/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Dancer-Plugin-Passphrase
+# Date created: 2012-01-24
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Plugin-Passphrase
+PORTVERSION= 1.0.0
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:JAITKEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Passphrases and Passwords as objects for Dancer
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Crypt-Eksblowfish>0:${PORTSDIR}/security/p5-Crypt-Eksblowfish \
+ p5-Dancer>0:${PORTSDIR}/www/p5-Dancer \
+ p5-Data-Entropy>0:${PORTSDIR}/security/p5-Data-Entropy
+RUN_DEPENDS= p5-Crypt-Eksblowfish>0:${PORTSDIR}/security/p5-Crypt-Eksblowfish \
+ p5-Dancer>0:${PORTSDIR}/www/p5-Dancer \
+ p5-Data-Entropy>0:${PORTSDIR}/security/p5-Data-Entropy
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Plugin::Passphrase.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Dancer-Plugin-Passphrase/distinfo b/security/p5-Dancer-Plugin-Passphrase/distinfo
new file mode 100644
index 000000000000..e77e302d9fc9
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Passphrase/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-Passphrase-1.0.0.tar.gz) = 252fd0d330db7e7efd03f20e71362f156fe0c0ce42dfd99aaf6f4241a4955444
+SIZE (Dancer-Plugin-Passphrase-1.0.0.tar.gz) = 15798
diff --git a/security/p5-Dancer-Plugin-Passphrase/pkg-descr b/security/p5-Dancer-Plugin-Passphrase/pkg-descr
new file mode 100644
index 000000000000..b9405232f169
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Passphrase/pkg-descr
@@ -0,0 +1,7 @@
+Dancer::Plugin::Passphrase manages the hashing of passwords for Dancer apps,
+allowing developers to follow best cryptography practice without having to
+become a cryptography expert. It uses the bcrypt algorithm as the default,
+wrapping Crypt::Eksblowfish::Bcrypt, and also supports any hashing function
+provided by Digest.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-Passphrase/
diff --git a/security/p5-Dancer-Plugin-Passphrase/pkg-plist b/security/p5-Dancer-Plugin-Passphrase/pkg-plist
new file mode 100644
index 000000000000..cd2a27a4360f
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Passphrase/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Dancer/Plugin/Passphrase.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Passphrase/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Passphrase
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/Dancer