aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-Perl-MD5
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-22 09:24:33 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-22 09:24:33 +0000
commitb4c79d2622a14bc242f5d65242bc80d51d259a56 (patch)
tree876396d1bad93a48e342f84adbc3cf761314e2ac /security/p5-Digest-Perl-MD5
parent89620ec805f3851ffdf667ab627ef3173d483c01 (diff)
downloadports-b4c79d2622a14bc242f5d65242bc80d51d259a56.tar.gz
ports-b4c79d2622a14bc242f5d65242bc80d51d259a56.zip
This is not an interface (like "Digest::MD5") but a Perl implementation
of MD5. It is written in perl only and because of this it is slow but it works without C-Code. You should use "Digest::MD5" instead of this module if it is available. This module is only usefull for computers where you cannot install "Digest::MD5" (e.g. lack of a C-Compiler). WWW: http://search.cpan.org/dist/Digest-Perl-MD5 PR: ports/90772 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151816
Diffstat (limited to 'security/p5-Digest-Perl-MD5')
-rw-r--r--security/p5-Digest-Perl-MD5/Makefile26
-rw-r--r--security/p5-Digest-Perl-MD5/distinfo3
-rw-r--r--security/p5-Digest-Perl-MD5/pkg-descr8
-rw-r--r--security/p5-Digest-Perl-MD5/pkg-plist7
4 files changed, 44 insertions, 0 deletions
diff --git a/security/p5-Digest-Perl-MD5/Makefile b/security/p5-Digest-Perl-MD5/Makefile
new file mode 100644
index 000000000000..6b4e77084f3a
--- /dev/null
+++ b/security/p5-Digest-Perl-MD5/Makefile
@@ -0,0 +1,26 @@
+# Ports collection Makefile for: p5-Digest-Perl-MD5
+# Date created: 21 Dec, 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-Perl-MD5
+PORTVERSION= 1.8
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for MD5 hash algorithm in pure Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Perl::MD5.3
+
+#WRKSRC= ${WRKDIR}/MD5
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-Perl-MD5/distinfo b/security/p5-Digest-Perl-MD5/distinfo
new file mode 100644
index 000000000000..22c085bfa282
--- /dev/null
+++ b/security/p5-Digest-Perl-MD5/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-Perl-MD5-1.8.tar.gz) = 8b54271ffe5f174456dd68b79bf3f8f3
+SHA256 (Digest-Perl-MD5-1.8.tar.gz) = 86b1f32a09ced075606d98a1b6ed24a44b2e18bfd0ab515dc987f99d9112d860
+SIZE (Digest-Perl-MD5-1.8.tar.gz) = 74077
diff --git a/security/p5-Digest-Perl-MD5/pkg-descr b/security/p5-Digest-Perl-MD5/pkg-descr
new file mode 100644
index 000000000000..d413c9b197d1
--- /dev/null
+++ b/security/p5-Digest-Perl-MD5/pkg-descr
@@ -0,0 +1,8 @@
+This is not an interface (like "Digest::MD5") but a Perl implementation
+of MD5. It is written in perl only and because of this it is slow but it
+works without C-Code. You should use "Digest::MD5" instead of this
+module if it is available. This module is only usefull for
+computers where you cannot install "Digest::MD5" (e.g. lack of a
+C-Compiler).
+
+WWW: http://search.cpan.org/dist/Digest-Perl-MD5
diff --git a/security/p5-Digest-Perl-MD5/pkg-plist b/security/p5-Digest-Perl-MD5/pkg-plist
new file mode 100644
index 000000000000..80bde8594b2b
--- /dev/null
+++ b/security/p5-Digest-Perl-MD5/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Digest/Perl/MD5.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Perl/MD5/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Perl/MD5/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Perl/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Digest/Perl/
+@unexec rmdir %D/%%SITE_PERL%%/Digest/ 2>/dev/null || true