aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-SHA-PurePerl
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2013-03-09 21:22:52 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2013-03-09 21:22:52 +0000
commit45ded33704105d644d8ce0ad056af147ad7f0357 (patch)
tree83484b70c848811b92f8790142ef4e3c310b4680 /security/p5-Digest-SHA-PurePerl
parentefd451bb07cdfa2430667ae18ec7c51c6a04b1a8 (diff)
downloadports-45ded33704105d644d8ce0ad056af147ad7f0357.tar.gz
ports-45ded33704105d644d8ce0ad056af147ad7f0357.zip
- Remove support for Perl < 5.12
- Convert to OptionsNG - Use PORTEXAMPLES - Convert Makefile headers to new style PR: ports/176267 Submitted by: Alex Kozlov <spam at rm-rf.kiev.ua>
Notes
Notes: svn path=/head/; revision=313756
Diffstat (limited to 'security/p5-Digest-SHA-PurePerl')
-rw-r--r--security/p5-Digest-SHA-PurePerl/Makefile29
-rw-r--r--security/p5-Digest-SHA-PurePerl/pkg-plist3
2 files changed, 8 insertions, 24 deletions
diff --git a/security/p5-Digest-SHA-PurePerl/Makefile b/security/p5-Digest-SHA-PurePerl/Makefile
index 8a3495b52aa2..40a0e25b6721 100644
--- a/security/p5-Digest-SHA-PurePerl/Makefile
+++ b/security/p5-Digest-SHA-PurePerl/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-SHA-PurePerl
-# Date created: 21 Dec, 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan <gabor@FreeBSD.org>
# $FreeBSD$
PORTNAME= Digest-SHA-PurePerl
@@ -14,30 +12,19 @@ COMMENT= Perl extension for SHA-1/224/256/384/512 in pure Perl
PERL_CONFIGURE= yes
-MAN3= Digest::SHA::PurePerl.3
+PORTEXAMPLES= dups
+MAN3= Digest::SHA::PurePerl.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500803
-RUN_DEPENDS+= ${SITE_PERL}/Digest/base.pm:${PORTSDIR}/security/p5-Digest
-.endif
-
-.if ${PERL_LEVEL} >= 501000
-PLIST_SUB+= EXE_FILES="@comment "
-.else
-PLIST_SUB+= EXE_FILES=""
-MAN1= shasum.1
-.endif
+.include <bsd.port.options.mk>
post-patch:
-.if ${PERL_LEVEL} >= 501000
@${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
-.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
post-install:
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/dups ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/examples/,} ${EXAMPLESDIR}
+
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-SHA-PurePerl/pkg-plist b/security/p5-Digest-SHA-PurePerl/pkg-plist
index dc5712fcf580..92a00cd59762 100644
--- a/security/p5-Digest-SHA-PurePerl/pkg-plist
+++ b/security/p5-Digest-SHA-PurePerl/pkg-plist
@@ -1,4 +1,3 @@
-%%EXE_FILES%%bin/shasum
%%SITE_PERL%%/Digest/SHA/PurePerl.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/SHA/PurePerl/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/SHA/PurePerl/
@@ -6,5 +5,3 @@
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/
@dirrmtry %%SITE_PERL%%/Digest/SHA/
@dirrmtry %%SITE_PERL%%/Digest/
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dups
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%