aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-SHA3
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-02-13 18:12:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-02-13 18:12:24 +0000
commit7ef62312f883c3e963db60a882b3437c2df112d3 (patch)
tree96b21ff15a3a7fefa71df80f8f46239f68cd9dea /security/p5-Digest-SHA3
parent3d76751389670d63edda52fa4a6860cef49b9f23 (diff)
downloadports-7ef62312f883c3e963db60a882b3437c2df112d3.tar.gz
ports-7ef62312f883c3e963db60a882b3437c2df112d3.zip
Add security/p5-Digest-SHA3, a NIST SHA3 implementation and perl interface.
Notes
Notes: svn path=/head/; revision=408819
Diffstat (limited to 'security/p5-Digest-SHA3')
-rw-r--r--security/p5-Digest-SHA3/Makefile19
-rw-r--r--security/p5-Digest-SHA3/distinfo2
-rw-r--r--security/p5-Digest-SHA3/pkg-descr10
-rw-r--r--security/p5-Digest-SHA3/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/security/p5-Digest-SHA3/Makefile b/security/p5-Digest-SHA3/Makefile
new file mode 100644
index 000000000000..19be542c2247
--- /dev/null
+++ b/security/p5-Digest-SHA3/Makefile
@@ -0,0 +1,19 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Digest-SHA3
+PORTVERSION= 0.24
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Perl extension for SHA-3
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Digest/SHA3/SHA3.so
+
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-SHA3/distinfo b/security/p5-Digest-SHA3/distinfo
new file mode 100644
index 000000000000..035155ffb638
--- /dev/null
+++ b/security/p5-Digest-SHA3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Digest-SHA3-0.24.tar.gz) = 49a7aa146f720877d557cf4c74c03c76ebf01c6dce94d374edb2610176941f5f
+SIZE (Digest-SHA3-0.24.tar.gz) = 28122
diff --git a/security/p5-Digest-SHA3/pkg-descr b/security/p5-Digest-SHA3/pkg-descr
new file mode 100644
index 000000000000..b5d5889f9a6e
--- /dev/null
+++ b/security/p5-Digest-SHA3/pkg-descr
@@ -0,0 +1,10 @@
+Digest::SHA3 is a complete implementation of the NIST SHA-3 cryptographic hash
+function, as specified in Draft FIPS 202 (SHA-3 Standard: Permutation-Based
+Hash and Extendable-Output Functions).
+
+The module gives Perl programmers a convenient way to calculate SHA3-224,
+SHA3-256, SHA3-384, and SHA3-512 message digests, as well as variable-length
+hashes using SHAKE128 and SHAKE256. Digest::SHA3 can handle all types of input,
+including partial-byte data.
+
+WWW: https://metacpan.org/pod/Digest::SHA3
diff --git a/security/p5-Digest-SHA3/pkg-plist b/security/p5-Digest-SHA3/pkg-plist
new file mode 100644
index 000000000000..92f26e4e75a7
--- /dev/null
+++ b/security/p5-Digest-SHA3/pkg-plist
@@ -0,0 +1,5 @@
+bin/sha3sum
+%%SITE_ARCH%%/Digest/SHA3.pm
+%%SITE_ARCH%%/auto/Digest/SHA3/SHA3.so
+%%PERL5_MAN1%%/sha3sum.1.gz
+%%PERL5_MAN3%%/Digest::SHA3.3.gz