aboutsummaryrefslogtreecommitdiff
path: root/security/p5-File-KeePass
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-03-15 12:42:09 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-03-15 12:42:09 +0000
commitcde6debf8a5711bb78c82e5eef0685fbe31c3c0d (patch)
tree46de62d68ab9bc7a385468ff48c1a6436834ad19 /security/p5-File-KeePass
parent24e58b70b8c631f6f8949ba2ab39096b46efcade (diff)
downloadports-cde6debf8a5711bb78c82e5eef0685fbe31c3c0d.tar.gz
ports-cde6debf8a5711bb78c82e5eef0685fbe31c3c0d.zip
File::KeePass is an interface to KeePassX and KeePass V1 database files.
It supports only Rijndael encryption and only bases which were secured via passkeys (key files not supported). WWW: http://search.cpan.org/dist/File-KeePass/ PR: ports/165922 (based on) Submitted by: Alexander Y. Grigoryev <alexander.4mail@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=293338
Diffstat (limited to 'security/p5-File-KeePass')
-rw-r--r--security/p5-File-KeePass/Makefile33
-rw-r--r--security/p5-File-KeePass/distinfo2
-rw-r--r--security/p5-File-KeePass/pkg-descr5
-rw-r--r--security/p5-File-KeePass/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/security/p5-File-KeePass/Makefile b/security/p5-File-KeePass/Makefile
new file mode 100644
index 000000000000..60172c3e3255
--- /dev/null
+++ b/security/p5-File-KeePass/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-File-KeePass
+# Date created: 2012-03-10
+# Whom: Alexander Y. Grigoryev <alexander.4mail@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= File-KeePass
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexander.4mail@gmail.com
+COMMENT= Interface to KeePass V1 and KeePassX database files
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Crypt-Rijndael>=1.0:${PORTSDIR}/security/p5-Crypt-Rijndael
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::KeePass.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-Digest-SHA>=1.0:${PORTSDIR}/security/p5-Digest-SHA
+RUN_DEPENDS+= p5-Digest-SHA>=1.0:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-File-KeePass/distinfo b/security/p5-File-KeePass/distinfo
new file mode 100644
index 000000000000..618ff7df5725
--- /dev/null
+++ b/security/p5-File-KeePass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-KeePass-0.03.tar.gz) = 858b9052ec05e7203e504fe8d8ccea0b936f814bd30f3192a4253d0c985743f4
+SIZE (File-KeePass-0.03.tar.gz) = 16264
diff --git a/security/p5-File-KeePass/pkg-descr b/security/p5-File-KeePass/pkg-descr
new file mode 100644
index 000000000000..50ac5242c49d
--- /dev/null
+++ b/security/p5-File-KeePass/pkg-descr
@@ -0,0 +1,5 @@
+File::KeePass is an interface to KeePassX and KeePass V1 database files.
+It supports only Rijndael encryption and only bases which were secured
+via passkeys (key files not supported).
+
+WWW: http://search.cpan.org/dist/File-KeePass/
diff --git a/security/p5-File-KeePass/pkg-plist b/security/p5-File-KeePass/pkg-plist
new file mode 100644
index 000000000000..de3c8d48639b
--- /dev/null
+++ b/security/p5-File-KeePass/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/KeePass.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/KeePass/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/KeePass
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File