aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Filter-CBC
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 10:17:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 10:17:13 +0000
commit9f37bc918845a5fe55687713c25b24ea1eaef366 (patch)
tree598d2b11cecaaf525fcf72ffa5e550d2e18c90db /security/p5-Filter-CBC
parent3662cec740c2302685cdffefbbda07c86560e689 (diff)
downloadports-9f37bc918845a5fe55687713c25b24ea1eaef366.tar.gz
ports-9f37bc918845a5fe55687713c25b24ea1eaef366.zip
add p5-Filter-CBC
Source filter for Cipher Block Chaining PR: 32770 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=51468
Diffstat (limited to 'security/p5-Filter-CBC')
-rw-r--r--security/p5-Filter-CBC/Makefile33
-rw-r--r--security/p5-Filter-CBC/distinfo1
-rw-r--r--security/p5-Filter-CBC/pkg-comment1
-rw-r--r--security/p5-Filter-CBC/pkg-descr9
-rw-r--r--security/p5-Filter-CBC/pkg-plist19
5 files changed, 63 insertions, 0 deletions
diff --git a/security/p5-Filter-CBC/Makefile b/security/p5-Filter-CBC/Makefile
new file mode 100644
index 000000000000..d979f9603526
--- /dev/null
+++ b/security/p5-Filter-CBC/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Filter-CBC
+# Date created: 11 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Filter-CBC
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Filter
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Filter::CBC.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/p5-Filter-CBC/distinfo b/security/p5-Filter-CBC/distinfo
new file mode 100644
index 000000000000..7f92e1cb7064
--- /dev/null
+++ b/security/p5-Filter-CBC/distinfo
@@ -0,0 +1 @@
+MD5 (Filter-CBC-0.07.tar.gz) = 04a1ed91b967bff89d96580473eddcec
diff --git a/security/p5-Filter-CBC/pkg-comment b/security/p5-Filter-CBC/pkg-comment
new file mode 100644
index 000000000000..f4bb2c9572ca
--- /dev/null
+++ b/security/p5-Filter-CBC/pkg-comment
@@ -0,0 +1 @@
+Source filter for Cipher Block Chaining
diff --git a/security/p5-Filter-CBC/pkg-descr b/security/p5-Filter-CBC/pkg-descr
new file mode 100644
index 000000000000..3131440e6eec
--- /dev/null
+++ b/security/p5-Filter-CBC/pkg-descr
@@ -0,0 +1,9 @@
+Filter::CBC is a Source filter that uses Cipher Block Chaining (CBC) to
+encrypt your code. The tricky part is that most CBC Algorithms have binary
+output. The textmode bypasses this obstacle, by converting the data to less
+scary data.
+
+WWW: http://search.cpan.org/search?dist=Filter-CBC
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/security/p5-Filter-CBC/pkg-plist b/security/p5-Filter-CBC/pkg-plist
new file mode 100644
index 000000000000..17714a236789
--- /dev/null
+++ b/security/p5-Filter-CBC/pkg-plist
@@ -0,0 +1,19 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Filter/CBC/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Filter/CBC.pm
+lib/perl5/site_perl/%%PERL_VER%%/Filter/cbc2code.pl
+%%PORTDOCS%%share/examples/Filter-CBC/autofilter.pl
+%%PORTDOCS%%share/examples/Filter-CBC/blowfish.pl
+%%PORTDOCS%%share/examples/Filter-CBC/defaults.pl
+%%PORTDOCS%%share/examples/Filter-CBC/des.pl
+%%PORTDOCS%%share/examples/Filter-CBC/des_ede3.pl
+%%PORTDOCS%%share/examples/Filter-CBC/gost.pl
+%%PORTDOCS%%share/examples/Filter-CBC/idea.pl
+%%PORTDOCS%%share/examples/Filter-CBC/null.pl
+%%PORTDOCS%%share/examples/Filter-CBC/rc6.pl
+%%PORTDOCS%%share/examples/Filter-CBC/rijndael.pl
+%%PORTDOCS%%share/examples/Filter-CBC/tea.pl
+%%PORTDOCS%%share/examples/Filter-CBC/twofish.pl
+%%PORTDOCS%%@dirrm share/examples/Filter-CBC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Filter/CBC
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Filter 2>/dev/null || true